Help needed to resolve: "doaction request return statuscode: UnknownError"

Roon Core Machine

Roon Nucleus+ running Roon Server Software Version 2.0 (build 1182 on Operating System Version 1.0 (build 254) and Roon Labs Software Version 1.0 (build 14).

Networking Gear & Setup Details

Starlink modem cabled to ASUS GT-AXE16000 router cabled to Cisco CBS110-8T-D switch cabled to Nucleus+. There is also an ASUS RT-AC5300 router in AiMesh mode also cabled to the ASUS Router GT-AXE16000.

  1. Who is your internet service provider?
    a) Starlink - Only the Starlink Modem is being used; the Starlink router is NOT being used.
    b) Astound/WAVE Broadband was being used in Dual WAN mode (aka backup Internet connection). BUT in order to get ARC to work I have disabled this WAN connection to avoid “Multiple NAT” issues.

  2. Please list the make and model of your modem and router?
    ASUS GT-AXE16000

  3. Do you have any additional network hardware, like additional routers or managed switches?
    a) Cisco Switch CBS110-8T-D (it is not managed)
    b) ASUS Router RT-AC5300 (AiMesh Node - aka a repeater, NOT doing routing including NAT )

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Chord Electronic M Scaler connected to Roon Nucleus+ via USB.
Four other audio devices connected via WiFi with ROON run on windows computers. Two computers, each with two audio devices connected.
One other device running on BluSound via WiFi (not Bluetooth) connection.

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}

Both UPnP and Port Forwarding have been enabled on ASUS GT-AXE16000 router.

The above error message occurs with or without a port forward rule being manually set.

My Nucleus+ 's IP address is static (Not assigned via DHCP) and defined to be

As noted above, I have disabled the Astound/WAVE connection to avoid Multiple NAT errors.

Before making changes to my router settings, I was able to use ARC on my phone when my phone was connected to my home’s WiFi.

  1. Please can you tell me how to further debug “doaction request return statuscode: UnknownError”. I suspect this is internal to Roon?

  2. Port Trigger is not set currently - can it be used instead of Port Forwarding for ARC?

  3. Would requests to my Nucleus+ come from a single Source IP address? If so, what is the address? I would like to include it in a manually created Port Forwarding rule in order to increase security.

Please let me know if you need any additional information, screenshots or need me to test something.

Thank you for your help and look forward to your response.

It’s best to use DHCP with address reservation in the router.

Moreover, the diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

However, since you have multiple routers, it’s possible you are running two subnets, and need to manually set up port forwarding in both.


Thanks for the quick response.

In ARC Port Forwarding ( it says:

Manual Configuration
If automatic configuration is not working, or if you’re prefer to to configure port forwarding manually, you’ll need to follow these steps:

Static IP - if you’re going to manually configure port forwarding, you’ll want to ensure your Core is always using the same IP address. This can be done by setting a static IP address on your Core or otherwise configuring your network to ensure your Core always uses the same IP

And thus the reason I used the Static IP address. The static address assignment was done in my router.

As I mentioned in original post, the second router (my old router) is not being used as a router or doing NAT. Its purpose is to expand the WiFi range. There are not multiple subnets because of the second router.

I have not found any setting in the router to control UPnP other than “Enable”, “Disable”, port trigger & port forwarding.

These are one and the same thing, and this is the more reliable method.

I would really like to have Roon ARC working. Is this the best way to contact Roon technical support team? My original post was 10 days ago and except for Martin’s responses which didn’t resolve the issue, I have not received any help. Is this normal turnaround time or am I missing something?

FYI - Because of Martin’s concerns, I did remove my second router from the configuration for testing purposes and didn’t see any changes in behavior - still received the same error messages.

Hi @David_Walp,

This is the best, and as far as i know, the only way to contact support.

Concerning your problem, could you turn of UPnP in the router. I read in some post on this forum that on some routers UPnP and a manual port forwarding not always works great.

The second question, you have a port forwarding to port 55002, just to be sure this is the port number shown in the Roon App under Settings → Roon Arc?

Kind regards,


1 Like

Hi @Maarten_Duits

Thanks for the prompt response and ideas.

Yes, I tried manual port forwarding with and without UPnP turned on with no change in results.

Yes, “55002” is port shown in Roon. (I think initially it may have been 55000 but quickly changed to 55002 to avoid a detected conflict?)

Again thanks for the ideas.

Hi @David_Walp,

I do have one suggestion, could you change the port number in the Roon app to ie. 441135 and adjust your port forwarding accordingly? I read on this forum that some ISP’s block certain ports.

If this isn’t working also, then i’m out of possibilities. I hope @support can assist you. They are very busy, so you unfortunately should have some patience. In the end they will help you.

Kind regards,


Hey @David_Walp
In case the last suggestion doesn’t work and since it may still be a while before support steps in, I can give you what works for me with my own Asus router.
So some screenshots of my settings, UPnP enabled, port forwarding disabled, no ipv6, DNS, etc.
After finishing router settings, reboot everything:
router and entire network, followed by a reboot of your roon core.

If it still doesn’t work, you could try bypassing the switch and try plugging the nucleus directly into the Asus router, then reboot everything.

I hope this helps so you don’t have to wait so long.

1 Like

Hi @Maarten_Duits,

Thanks for the suggestion. Unfortunately, 441135 appears to be too large for a port number. In Roon, the port number is limited to 5 digits and my router say the port number needs to be in the range of 1 to 65535 (aka 2^16 - 1). Are you suggesting a port number in the registered range of 1024 to 49151 as opposed to 55002 in the dynamic range of 49152 to 65535? Maybe there are too many “4” or “1” digits in your suggested port number?

Thank you

Hi @Axel_Lesch,

Thanks for detail ASUS information. Will give your suggestion configuration a try tomorrow (hopefully) when I can reboot everything without upsetting the rest of the household.

EDIT: Looking at my router configuration, my IPv6, AiProtection, Apps analysis and Traffic Analyzer - Statistics, already match your suggested configuration.

Hi @David_Walp,

I’m sorry i typed in the wrong number. My suggestion was to change it to port number 44135.

Kind regards,


@Martin_Webster @Maarten_Duits @Axel_Lesch

Thank you each for your time & help!

Maarten - Tried port 44135 - no luck

Axel - Rebooted both routers, switch, and the Nucleus+ as you suggested - no luck. Also eliminated the switch from the configuration by plugging the line from the router directly into the Nucleus+ - again no luck.

BUT I had a duh moment. As I said in my original post, I have two ISP in our home, so I switched the ISP from Starlink to Astound/Wave. IT WORKS! (using Axel’s configuration)

My plan was to end Astound/Wave service once the winter weather was over and Starlink proved itself more reliable. Our home is literally the last home on the Astound/Wave cable line; our next door neighbors in two directions can’t get Astound/Wave service. So far Starlink has been A LOT more reliable for us.

So the question is now, What needs to be done to the Starlink configuration to enable it to support ARC? Has anyone out there, have any success with using ARC on Starlink?

Hi @David_Walp,

That’s good news! Enjoy Roon Arc!

What to do….I think it’s a good idea that you call the ISP and ask them if they block any ports or implemented CGNAT. Concerning CGNAT, on this forum there are some questions posted you could ask your ISP. I don’t have them by hand. I will do a search tomorrow and let you know.

Kind regards,


That’s good news!

It doesn’t look good for now, I’m afraid.
However, Roon keeps pointing out that they are actively working on a solution and making progress.

@Axel_Lesch @Axel_Lesch Thank you both for your help. It appears that the issue is well documented and understood. My fingers are crossed that a solution is found.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.