Static When Upsampling 24/192 to DSD or PCM (384kHz)


I have a very strange issue with ROON 1.3 and HQPlayer 3.13.3.

My setup is as following:

Roon Core 1.3 on NAS QNAP-TS453pro >> HQPlayer (3.13.3) on a dedicated PC (i5-6600T, 16Gb, WIN2016 Core, AO 2.20, Fidelizer Pro) >> Musical Paradise MP-D2 DSD DAC

I upsample everything to DSD128 using poly-sinc-mp/DSD7. Everything plays fine until I try to upsample the 24/192 track to DSD. HQPLayer would play normally for several seconds and then the static noise starts. The static can play sometimes for several seconds switching back to normal music, and sometimes static plays to the end of a track.

Now the interesting part. If I turn on the DSP on Roon and use any of the DSP features like Headroom, EQ or Speaker setup the 24/192 content plays file without any static. I think it has something to do with the “Bit Depth Conversion” 24-64 and then 64-32. So my conclusion is that 24/192 causes static while 32/192 doesn’t when upsampling to DSD or to higher PCM (384kHz).

I tried different settings and filters in HQP with the same result. I never had that issue with ROON 1.2.

My solution for now is to use a small (-0.01) gain adjustment in the Speaker Setup so it would cause the Bit Depth Conversion from 24 to 32. But that puts unnecessary load on my NAS.

Lets give @support a shout.

My problem is described in the post above. Can @support help me please?

Hi @Go_Ga ---- My sincere apologies for the slow response here. I have coordinated with a team member who is using a similar setup to your’s to see if we can reproduce this behavior in house using the feedback you have provided. Once our testing has completed, you will hear from me immediately with our results.

Again, apologies for any frustration and thank you for your patience while we conduct our testing.


Hey @Go_Ga – I just tried to match your setup and I’m not having the same issue. My Signal Path looks like this:

Are you seeing the same thing? Just want to make sure we’re running the same test before we move forward.

Looking forward to getting this resolved for you soon – thanks!

Hi @mike,

Here is what I have:

Ok, I’ve changed settings here to match yours exactly:

Still no luck reproducing this :frowning:

Would you mind updating to the latest HQPlayer? Maybe that’s the difference between your setup and what we’re seeing here.

Let me know how that goes and we’ll go from there. Thanks!

Hi @mike,

The issue is still there. I just tried HQP 3.15 with the same result. Got static after 4 seconds.

Hi @mike and @Eric ,

Any update on my issue?


Hi @Go_Ga – we haven’t had any luck reproducing this in house.

I’m going to discuss this with our developers, but it might be worth checking with @jussi_laako too, since he may be aware of other reports. If audio seems to work for a few seconds and then fails, that tells us that at least initially Roon is formatting the stream in a way that HQPlayer can understand.

There is another possibility here I’d like to rule out – can you reproduce this issue one more time, and then zip up your logs folder for me?

You can find your logs here – can you upload the zipped up logs folder to Dropbox and get us a link?

1 Like

I’m having the same issue - HQ Player upsampling to 5.6 DSD poly sinc shirt ASDM5/7 via a microrendu into a Nuprime DAC10H. Only an issue since the Roon upgrade. Noticed first with 24/192 tracks but now getting same issue with any track with a dynamic range of “7”. This is only an issue with 1.3 roon.

PC is a skylake i7 6700k with lots of ram and cuda offload to a GTX1070 nvidia card so should be plenty powerful enough

Watching this thread with interest as I can’t live without HQ Player!

Hi @mike,

I have sent you a PM with the logs. I also noticed that sometimes I get static even with 24/96.


Thanks @Go_Ga – the logs are with our developers and I should have some feedback for you soon.

Thanks again for your patience!

Hi @mike

Any update on my issue?


Hi @Go_Ga – thanks for your patience here.

We looked over your logs and while we didn’t find any obvious bugs or causes, we were able to confirm that Roon’s buffer isn’t emptying out before this issue occurs. What this means is that Roon is delivering the data in time and, since you’re at least initially getting playback, that Roon is delivering audio data that HQPlayer can understand.

Have you checked with @jussi_laako about this yet? I’m interested to know whether he’s heard any similar reports or is aware of anything that might be causing this issue.

Stand by @Go_Ga – we’re going to continue looking into this, and I’m confident we can figure out what’s going on here. Thanks!

I just noticed this myself. I just got a new DAC so I thought it may be related to that because with my previous DAC I did not have any issues with static. I also use Roon and HQP, converting all my PCM to DSD256. The static I get is infrequent and not very loud though still noticeable. At least for me I think it is being caused by either my new DAC or the cabling.

In my case the issue is not caused by the DAC or HQP computer but rather ROON 1.3 itself. I have 2 systems with different computers running HQP and feeding 2 different DACs and the issue happens on both systems.

In my case the music starts playing initially and then breaks up after a few seconds. I first noticed this almost immediately after I upgraded Roon to 1.3 (when I first played a 24/192 file). It never happened before and I haven’t changed any settings in HQ Player since the upgrade to 1.3. Will message Jussi to see if he has heard anything similar.

This gain/static part is new to me, I have not encountered such.

Only gain related thing that comes to mind is that it is good to check that HQPlayer volume is not turned higher than max -1 dBFS when doing upsampling, recommendation being -3 dBFS…

Now starting with 3.15.1 version HQPlayer will indicate gain settings that are likely to trigger the limiter in the volume knob color. As usual it is also good to check with the latest HQPlayer version too if the problem still persists.

I’ve sometimes managed to get to situation where Roon starts streaming data and then it dries up (cuts the connection), so HQPlayer eventually first gets short read and then 0 from recv(). And the stream is gone even if I re-request. I reported this to Brian a while ago. But this is somehow timing related, so it is very hard to reproduce reliably.

Just to be clear that by “static” I mean white noise without any music at all.