Steadily blinking light on NUC -- strange sleep mode?

Hi all,
I’ve been enjoying Roon for a week or so and have been learning a bunch in this community. Holy cow this is enabling me to enjoy music like I haven’t in years!

I put Roon on a NUC this weekend (a NUC7i7DNHE running Windows 10 Pro). Late yesterday the front power light began steadily blinking, which the Intel support docs say is for a BIOS update, but the blink seems to go on indefinitely — until I access Roon via the app on my iPhone, at which point the light goes back to a steady on state and everything appears to behave as expected.

However, doing the same from the Roon app on my MacBook does not do this: Instead, it continues to blink and Roon says that the core is unavailable. This continues until I either run Remote Desktop and connect to the NUC, or access it with my iPhone. So, I’m wondering if this is some slightly strange sleep mode? My understanding is that Roon doesn’t support wake-on-Lan, but that’s sure what it feels like it’s doing — albeit only when pinged by the phone or by remote desktop.

Or perhaps something else is happening? At one point last night, Roon reported that no audio devices were found. Rebooting the NUC appeared to resolve that for now, and my Airplay, MacBook and iPhone audio outputs all appeared again.

I’d love any feedback on what may be happening and whether these two events are related. Thanks, all!

I may have an answer to my own question, so posting an update to share out.

A little more googling around got me more info on the NUC’s sleep states, and I verified in the BIOS that the continuous fast blink corresponded to S3 – a lower-power state that’s not quite asleep. I changed the power LED to amber and a slower fade at S3 to confirm, and sure enough, it swaps over to that mode when it’s not in use. (The fade is still pretty fast! But at least it’s a more soothing color…)

I still don’t understand why a request from iOS to Roon wakes it up while a request from the desktop Roon app doesn’t do so, but I’m at least satisfied that I understand the state it’s in. I think I’m actually pleased that it’s not always in the high-power state, and there’s more I’ll probably tinker with there between the BIOS performance settings and the Windows settings.