Still: Squeezebox Touch Not Seen By Roon

I’ve had Roon for a few months and would like to use it in a secondary system that has a Touch for a source. I have read the postings on this topic and tried to follow the suggestions but still Roon doesn’t see the Touch. One key part of the advice is make sure LMS is not running anywhere on the network. It’s possible that I don’t understand how to insure it is disabled or not running. Is this correct: to insure LMS is not running, just don’t have any web browser on your network with the LMS web page open?

Roon on Late 2015 iMac, 2.8 GHz Intel Core i5, 8 GB memory. Music stored on attached HD. Motorola cable modem, router is an Apple Time Capsule. Ethernet from router to upstairs music room into Sonore Ultrarendu, USB into PS Audio DirectStream DAC.

Squeezebox Touch is downstairs in second system with a wireless connection.

The wireless connection to the Touch works because if I start LMS on the iMac (go to webpage localhost:9000) the Touch plays music from my HD.

No LMS is an app that runs on a device in your network, usually a PC, Mac or Linux device. The fact you can open a LMS browser page would indicate you have LMS running somewhere.

Many thanks Tony, that’s great news, means once I figure out how to turn LMS off it should be all set.

Very impressed with instantaneous customer service !!

:grinning: remember most of us are just users like you helping each other. If you access LMS via the browser it may give you an IP address along the lines of the :9000 part is just the port used by LMS. If it is then LMS is running on the same machine as the browser. In any case I think somewhere in the browser session you can stop LMS. Sorry to be vague but it is years since I used it.

even if you have LMS running somewhere, with the Touch you should be able to switch to your roon server.

on the Touch, go to audio settings, and look for music source. it may be in advanced settings.
when i’m in front of my touch later i will try and find the exact path.

in any event, there should be a list there that allows you to switch to the machine that hosts roon.

a complication would be if you’re running roon on the same machine as LMS, in which case you need to shut LMS off.

on your imac, go to apple menu–>system preferences. in the lowest row of preference panes, do you see Logitech Media Server listed? if so, open it, and if it’s “running” click stop.

On the Touch itself you can force it to change the server/library its in network settings if I remember. If you do this you should see you Roon server name as an option. It might not switch.but if you see it then Roon is configured right for squeebox. If not then ensure you have all the squeebox settings turned on in Roon and its.running on the same subnet .

Thanks woodford and simon_arnold. Roon now sees the Touch. Key was woodward’s suggestion: on the imac, go to apple menu > system preferences, click on Logitech Media Server, click stop server.

Then what simon said, approximately.


Yes, I switched my Squeezeboxes over when Roon added support. Gave new life to the hardware.

Glad it’s working. I just got my touch back up and running using EDO to a Schiit Jotunheim. Makes for a very simple, great sounding headphone system.

It’s working very well, love it. This second system it’s in distributes music to 5 rooms in the house, so nice to hear my Roon library playing for background while doing other things. And I showed my wife how she could use it to find and play anything (almost) she wants via Tidal. She seemed interested so I put the Roon app on her phone.