Strange alarm behaviour on new Pi 4 with Ropieee

I’ve run into a confusing situation with the Ropieee alarm function and I’m curious whether anyone knows why this might be happening.

I had been successfully using the Roon/Ropieee alarm function on a Pi 3B for quite awhile to turn on white noise in the morning on a Roon radio channel playing through Sonos speakers in my bedroom in an effort to block out neighbour noise. I have Pi 3s running in my home, with only one configured with the alarm. So far so good. Last week I purchased a new Pi 4 to replace the Pi 3 on which the alarm had previously been configured. I burned a new card with Ropieee and got the new Pi 4 up and running. I configured the alarm and it worked—but the alarm started five hours before the scheduled time. The 5.45 am alarm started playing my white noised at 12.45 am. I tested for two nights—same thing. I removed the alarm and reinstalled it. Same thing again.

I removed the alarm entirely from Roon and the Ropieee configuration on the new Pi 4 and instead enabled it on one of my older Pi 3s. I configured it for the same time, white noise and Sonos speakers. It worked like a charm, at the correct time.

In the end, this solution works for me. But I can’t understand why the new Pi would activate the alarm early. It’s almost as if it is set for a different time zone, except as far as I’m aware there are no time zone settings in Ropiee unless you use a video screen (which I do in another home I have in another country).

Any ideas why this might have happened? Thanks in advance.

This is a timezone issue.

A loooong time ago the timezone setting was on the first tab in the interface.
At some point I moved it to the display tab because it’s not a setting that is mandatory.
In hindsight that was a bad choice because if you use the alarm clock (or the timed reboot setting) the timezone is indeed a factor.

Long story short: in the next version this is fixed and you will be able to set the timezone from the ‘advanced’ tab.

2 options for you: wait for that release (somewhere in the coming weeks) or switch to the beta channel (which brings some risk).


1 Like

Thanks, Harry, for the explanation. It’s good to hear that it will soon be resolved. As I mentioned, I got the alarm working by using another Pi, which probably has the correct time zone settings because it’s been in use with Ropieee for quite awhile. So I can definitely wait until the next version instead of going with the beta. I appreciate all your hard work on Ropieee.

1 Like