Strange Audio Issues w/ Ventura [Roon Investigating; Known Apple Issues w/ Ventura System Audio]

Hi @Daniel_Bykhovsky,

We continue to reproduce this inconsistently internally, and we’ve submitted a Radar report to Apple to address coreaudio issues with the initial release of Ventura.

As you’ve mentioned, this issue appears to be unfortunately widespread, and not limited to Roon’s interaction with the system output. That said, Roon’s designated this as an Apple bug internally, we’ll continue to investigate if there is a potential workaround or improvement we can make to stabilize Roon’s all-in-one performance on Ventuera.

In the meantime, I recommend the terminal Core Audio reset as an alternative to restarting the computer or relaunching Roon:

Using terminal to reset Core Audio on the Mac. Go to Applications → Utilities → Terminal . Type in “sudo killall coreaudiod” and press Enter . This should reset your Core Audio daemon.

We’ll post an update here as we have additional news. Thank you for your patience.

1 Like

Glad to see this is a know issue. My iFi Zen DAC v2 is only occasionally recognized by Roon in Ventura. Unfortunately, restarting Core Audio does not solve the issue. This currently renders Roon usable. Hopefully a forthcoming MacOS 13.1 update rectifies the issue. If you’d like to run any further testing, please let me know. Cheers!

MacOS 13.1 has been released. Let’s see if we continue to experience the same issues.

By no means has my testing been exhaustive, however, since upgrading to MacOS13.1 I have not experienced this previously frequent issue.


Yes, it seems that the problem has gone away with Ventura 13.1.

1 Like

13.1 has not resolved this for me. My Schiit DAC is often not recognized by my 2021 16" MBP. Often I’ll look in Audio Midi Settings to see what’s going on and often, but not always, that application will hang and I’ll have to force quit it. This is a recent issue for me and, though I can’t say for sure, seems to correspond with my upgrade to Ventura. The workaround that @connor suggested does typically work for me. Patiently awaiting any news here!

I too occasionally need to “sudo killall coreaudiod” in order to see my iFi device.

I do appreciate the reminder. I’ve tried it and it worked sometimes, not others, and has stopped working at all. Nothing will make my Schiit dac visible.

Tried different cables, different ports, no luck.

Audioquest Dragonfly black via USB C adapter works fine.

Tried going through a powered USB hub that I have some external drives plugged into. That worked, but I got an error message that a USB accessory was drawing too much power and would be shut down. The dac worked at that point, and I don’t think the total power draw of 2 drives and a dac exceeded the power available from the USB port. However, I didn’t want to fry the port, so I dropped that solution.

I tried a separate powered USB hub, didn’t work.

My answer has been a WiiM Pro streamer. Coax out of the streamer into the dac, works like a charm. Maybe a future mac OS update will fix it one way or another, but that’s my story!

1 Like

And today, just for the heck of it, I plug in the USB cable and it works. Didn’t reboot anything, didn’t power cycle the DAC, didn’t reset core audio. I don’t think this is a Roon issue, so I haven’t persisted with posts here - more likely a mac OS issue, in my opinion. Or gremlins, I suppose. Maybe I have to find another place in the house for the streamer now?

1 Like

Back to normal today. No recognition of the dac, no change with a reboot or a reset of the core audio daemon, before or after the reboot. I guess the streamer sticks around just in case!

I am still plagued by this issue. Successfully finding and being able to use system audio devices in Ventura has been incredibly spotty. multiple time per day I am forced to sudo killall coreaudiod in order to successfully play music. I do not experience this issue with any other program.

I took advantage of Roon’s Black Friday deal which ends on 2/23. This issue has been prevalent for the entirety of this onboarding period. I love Roon’s metadata, Tidal integration, ARC, and whole home management. However, my primary listening station, an iMac, repeatedly fails at conducting this software’s primary function, listening to music.

Roon has “designated this as an Apple bug internally” so it appears we’re waiting on an unknown Apple fix. As Ventura has already reached 13.2, I think it’s fair to say Apple does not believe there is a continuing issue.

Hi @danofun,

Looking through diagnostics on your account, there are traces related to the iFi and iMac System Output Zones that suggest there might be a more localized problem in your networked audio setup. The tech support team has a few steps and questions that might illuminate the issue and help restore more stable playback on this Remote and Endpoint:

  1. This iMac is reporting to Roon that it’s low on file descriptors. The machine appears to have significant processing power and storage capacity, so the issue here is likely easily resolved. Do you have a large number of other software programs running continuously alongside Roon?

Mac OS enforces an open file descriptor limit, unlike other operating systems, and with Ventura, the steps to increase the limit are slightly different. We don’t have hard evidence this is causing performance issues on your iMac, but it wouldn’t hurt to investigate the responses in this thread for some easily Terminal commands to raise the hard ulimit on your iMac: macos - How to increase global maxfiles ulimit on OSX 13.1 Ventura - Ask Different

  1. Your iMac is refusing the connection from your Core at times. Do you have any network VPNs or firewalls open on this computer? Is your Core still hardwired? I recommend refreshing RAATServer by following these steps:
  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder
  1. If Roon is not losing sight of the system output when the iFi disconnects, then this issue is unrelated to any known Ventura audio kernel issue, and we’ll proceed to troubleshoot as an Endpoint connectivity problem. Disable any DSP and test to see if the iFi loses connection with any specific file types or content. Do streaming services work? What about local files?

We’ll keep an eye out for your response.

@Connor thank you for the message.

  1. I’ve raised the hard ulimit as suggested
  2. No open VPNs or firewalls. Core and iMac exist on the same pfSense network/subnet. I’ve regenerated the RAATServer folder as instructed.
  3. Both streaming services (Tidal) and local files (.flac & .m4a) work when the iFi is recognized

I’ll disable DSP and report back the results paying close attention to specific source and filetype when an error is encountered. Cheers!

The limits are pretty darn high in macOS Ventura 13.2.1:

~$ sysctl kern.maxfiles
kern.maxfiles: 307200

~$ sysctl kern.maxfilesperproc
kern.maxfilesperproc: 153600

While still high, I believe the defaults for macOS Ventura 13.2.1 are:
kern.maxfiles: 245760
kern.maxfilesperproc: 122880

I’ve been out of town for the better part of the week but am back at the iMac today. Initial attempt to play resulted in the following error:

02/21 14:52:03 Trace: [iFi (by AMR) HD USB Audio ] [raatclient] GOT [6] {"status":"DeviceInitFailed","message":"RAAT__OUTPUT_PLUGIN_STATUS_DEVICE_INIT_FAILED"}
02/21 14:52:03 Trace: [iMac iFi] [zoneplayer/raat] device init failed. stopping stream
02/21 14:52:03 Info: [audio/env] [zoneplayer -> stream -> endpoint] All streams were disposed
02/21 14:52:03 Info: [audio/env] [zoneplayer -> stream] All streams were disposed
02/21 14:52:03 Warn: [zone iMac iFi] Track Stopped Due to DeviceInitFailed

Running out of days here but to eliminate variables I’m moving my core to a dedicated NUC with a clean install of Ubuntu Server 22.04.

New Core, same error.

02/22 15:21:17 Trace: [iFi (by AMR) HD USB Audio ] [raatclient] GOT [6] {"message":"RAAT__OUTPUT_PLUGIN_STATUS_DEVICE_INIT_FAILED","status":"DeviceInitFailed"}
02/22 15:21:17 Trace: [iMac iFi] [zoneplayer/raat] device init failed. stopping stream
02/22 15:21:17 Info: [audio/env] [zoneplayer -> stream -> endpoint] All streams were disposed
02/22 15:21:17 Info: [audio/env] [zoneplayer -> stream] All streams were disposed
02/22 15:21:17 Info: sleep 0ms after flush
02/22 15:21:17 Warn: [zone iMac iFi] Track Stopped Due to DeviceInitFailed

After countless “failed to initialize the audio device” messages, and not being able to play anything at all, I’ve deleted these 2 folders:

Playback has resumed.

After exiting and reopening Roon, playback repeatedly fails with the same error as above. After deleting the above folders, opening Roon, and enabling the iFi device playback immediately works.

I will continue to update this post.

My trial has ended without a resolution. First stated experiencing this issue on 12/5/2022.

Hey, my usb dac is back today! I did reset coreaudio, but much of the time that makes no difference. Running Ventura 13.2.1. We’ll see how long this lasts.

1 Like

How’s it going?!