Stream Qobuz with VPN

Hi,
I have a Qobuz account from US which I normally access using VPN on my mobile phone.
Recently, I have signed up for Roon. I am trying to use Qobuz within the Roon app on my iPad, however once on VPN, the Roon system cannot identify the Roon core at home.
May I know how can I use the Qobuz with Roon effectively with VPN?

Thank you in advance.

s.lai

You need to ensure your L2TP based VPN is Ethernet bridging between your remote and local networks… that is you need to ensure a LCCE (L2P Control Connection Endpoint) is configured at each end of the VPN.
Ensure multicast is enabled on your bridge, perhaps with terms like LAC for client and LAS for server.

I doubt you can do this with a simple client based VPN… but worth checking with your software provider.

If you have a valid user account with Qobuz you should not need a VPN whatsoever to stream. Once you’re signed up with Qobuz you can stream in any country on the planet. My account with them is in Europe but I live in Asia now. No need for a VPN at all. Neither for the Qobuz mobile apps nor for Qobuz in Roon.

Hi Simon,
Thank you for pointing out to me, although this is too technical for me (non-IT) guy here. Nevertheless, a good starting point for me.
Could you kindly advise how do I go about ensuring a LCCE (L2P Control Connection Endpoint) is configured at each end of the VPN? Eg. What configurations do I need to do on my ipad, and what is needed to be done on the other end? Does the other end refers to the Roon app?
Pardon my amateurish question.

Thank you

s.lai

Interesting point you have made here. I have signed up the Qobuz account in US, paid with US credit card done in US. But now am in Asia, interestingly, I need to use VPN to access Qobuz on my mobile phone. But on my ipad using roon, I cannot identIfy the roon core at home once on VPN. If I do not go on VPN, I cannot play any songs from Qobuz.
I do not quite understand the issue I am facing at the moment.

s.lai

Probably not appropriate for this forum… I would contact your vpn software provider technical support and ask them how to set up an ‘Ethernet bridge’ up with their product… and have multicast enabled… that way you will quickly find out whether you have the appropriate VPN software or not.
Your client is on your iPad… so what are you running the VPN server (LCCE) on in your home network? Perhaps a PC or similar … I assume that is also provided by your VPN software provider?

So no the ‘other end’ is not the Roon app… it’s the VPN server on your homenetwork that you will have remotely connected to from outside your home network on your iPad … (likely you will have set your router to assign its default inbound LAN address to your VPN server, might be referred to as a ‘DMZ device’.). Ensure your Roon server and the VPN server (from your VPN software provider) are in your same home network…, ensure your Remote iPad VPN client connects to the public IP address on your internet router.

This guide on how to setup a home vpn server might be helpful. This is what you need to do to remotely access your Roon running on your home network.

Home network does not have VPN. VPN is currently only available via iPad (work related), and mobile phone (free VPN). The rest you mentioned are very new to me.

I have a US Qobuz subscription and use it on Roon from abroad with a regular connection. A VPN is not necessary. Just enter your credentials and you’re good to go.

Could you kindly explain what you mean by credentials?

Credentials: Login name / password

Already done so for the past few months.

Strange, I can only agree what Benoit wrote before. I use Qobuz as well in different countries without any problems w/o VPN connection.

To be more specific, when am not on VPN trying to play Qobuz via Roon, I have the following msg “Unable to start streaming. Check your Qobuz account and try again. Too many failures. Stopping playback.”

That sound more like an unstable internet connection -> “packet loss” or “bad latency”.

I have been making some experiments past few days after chancing upon some changes recently. It happened when I played an album from a particular singer and when the album finished, it didn’t go to another song within my hard disk, but a song from another album from the same singer from Qobuz! However, it played for a few seconds before stopping.

I tried playing Qobuz again via Roon with this discovery, it appears playing Qobuz from Roon is not smooth at all, any music will have to wait for a few seconds before starting to play, and after a few seconds, it will stop.

I tried again late at night (am in Shanghai), this issue becomes less problematic. I can play music from Qobuz continuously although the duration between pressing play to the music being played takes a few minutes.

Once comes morning, the original problem comes back.

I made another experiment using my Qobuz app on my android mobile phone. I can now play any music in Qobuz without any VPN, using both my mobile phone data or home broadband with similar positive results.

I made an interesting discovery comparing using Qobuz on my android mobile phone and Qobuz via Roon (both using home broadband). I can play Qobuz smoothly on the android mobile phone and Qobuz via Roon is problematic, as described above.

I wonder anyone can help me to understand the issue I am facing and direct me to solve my issue.

Any help rendered is greatly appreciated.

Thank you.

symon

Roon Core (Mac Mini) CAT 7 cable direct to Service Provider Router

Tried at mp3 320kbps, still the same issue. Now it’s 1 past midnight here, still facing the same issue, while the Qobuz on the android mobile phone is playing flawlessly.

“Qobuz media is loading slowly. This may indicate a networking or connectivity problem.” Received this message at all different streaming qualities (from the lowest MP3 320kps to Hi-Res 24-Bit / Up to 192kHz).

I think I may have found out the main reason, lack of bandwidth from the service provider router. Have plugged in an old wireless router to the service provider (roon core is connected directly to this old wireless router), and now Qobuz via Roon is playing flawlessly. Will have to observe this again tomorrow in the day.

2 Likes

The problem is back after upgrading to 1.8 :joy:…wondering if I should upgrade the old wireless router (Apple AirPort Extreme).

Ipfire will work. Guaranteed. I’ve tested.