Struggling to Connect, Unusual Mac Error

I don’t, sorry.

Are your network addresses in the form 192.168.0.x?

1 Like

Sort of, it’s 192.168.1.xx

Your router software is either 192.168.1.0 or192.168.1.1.

Enter address into a browser window. You will be presented with a signon screen. Logon/password will probably admin/admin or admin/password.

Once in, look for a list of your connected devices and note the MAC address of the device you want to assign static IP to.

Look for a menu pick that talks about reserving addresses. Pick an IP that you want to make static (e.g. 192.168.1.xxx)and assign that along with MAC address.

1 Like

You can set the static IP for the Roon Core (Mac) on the Mac, no need to do it on the router.

Open System Preferences and select Network. Choose Ethernet from the left column then in the Configure IPV4 drop down menu choose DHCP with manual address. Set the manual address to the 192.168.1.xx number that your router uses. In my case I chose an easy to remember number on the higher end of the range (between 1 and 255). This number should be one that’s not assigned to another device on your network. Setting it to a value near the end of the range of possible numbers should assure that’s the case unless you have hundreds of devices.

Then at the bottom of the window click the Apply button, close the Preferences window and you’re done.

1 Like

Sorry, I must disagree with this. Setting a static id directly on a device has the potential to confuse DHCP in the router and cause an address collision, which might be difficult to diagnose.

2 Likes

True, though I’ve never had this issue.

Also true, but why take chances when doing it in the router is almost as easy?

If an address collision does occur, which I have seen in this forum, it’s a bitch to realize that’s the problem and who needs more mystery as far as Roon networking is involved. :grin:

1 Like

Thanks both for your help. Does it matter that my MacBook Pro isn’t always wired?

I.e. Because it’s my only computer the way I use it is with WiFi for general usage during the day, and then when I want to listen to music in the evenings I plug in the LAN cable for a more secure connection.

Could this be confusing things or does it not really matter?

Wired vs. WiFi will be two different IPs and (as I recall) two different MACs. Just set both.

As to your original problem, I have no opinion, but take @Martin_Webster’s expertise on that.

Not sure why you don’t just use Ethernet all the time, but whatever. :sunglasses:

I guess you want to move around with the laptop?

1 Like

It doesn’t matter*, but this is the likely reason you see the message: the lease expired and the IP got reassigned.

Set fixed IP (address reservation, which will require the MAC addresses for each interface) in your router for both interfaces, and leave the Mac settings for DHCP alone.

*Your core is likely to perform better using Ethernet.

1 Like

7 posts were split to a new topic: DHCP and address reservation

Thanks again.

I managed to find my router hub on the web and identify and rename all my devices; this is what it looks like:

Do you have any ideas on how to set a fixed IP for my MacBook Pro on Ethernet and WiFi?

I’ve not used BT for a while, but I think you go to Advanced settings, My Network (as in your screenshot), select the device, and there should be an option to always use the address.

Note that you’ll need to do this for both Wi-Fi and Ethernet interfaces on the Mac.

2 Likes

This is the device page for the MacBook Pro on Wifi

‘Always use this IP address’ is already toggled to YES.

And this is the MacBook Pro on Ethernet:

This error has nothing to do with ip addresses. It’s about the hostname’s computer (and bonjour / netbios). For some reason, it thinks that another device with the same hostname exists on the local network. Best to give your device an actual name under System Preferences > Sharing > Computer name.

3 Likes

Hey @Chris_I,

@Nepherte is steering you in the right direction here, as this doesn’t seem like a roon-specific issue. Rather, this issue is more tied to your computer itself.

Let us know if renaming helps :+1:

Hi Ben, thanks for checking in; yep I think it was caused by the way I was using Roon (going between wired and WiFi too often) but Roon is not to blame! In any case I haven’t had the problem since I posted. I don’t think I did anything to ‘solve’ it but that’s computers!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.