Stuck Initializing Connecting to New Mac Mini Core - Resolved

Roon Core Machine

Mac Mini, OS Monterey 12.4, M1 CPU, 16 GB RAM (Core Machine), 256 GB SSD, RoonServer 1.8 (build 970), Connected to ethernet hub (no wifi used) - see below.

Networking Gear & Setup Details

Combined wifi and wired network, Linksys two-node Velop mesh network for wifi, Velop configured as router connected to cable modem and to an 8-port ethernet hub.
Mac Mini core connected to ethernet hub (no wifi used) and the iMac running Roon app used to remote into the Mac Mini core is also only using ethernet (via an ethernet-over-powerline adapter to the hub). The two machines are on different floors in our home.

Connected Audio Devices

At this point only wifi streaming to KEF LSX speakers and to Yamaha receiver but have not been able to do so using the new Mac Mini core as I’ve been unable to port the existing core to it.

Number of Tracks in Library


Description of Issue

I set up a new mac mini as a roon core (just installed the roon server software) and can screen share from the iMac to it. When trying to transfer the core function to the mac mini, I screen share into the mac mini from the iMac, I see that the Roon server is running on the mini, I start Roon on the iMac and it attempts to connect to the new core, but it stays stuck at initializing (with a red dot).

I’ve reinstalled the Roon app on the iMac and the mac mini and I turned off the firewalls on both machines. I’m at a loss as to what to try next. Any advice is welcomed.

Update: I tried using wifi with the mac mini and remote computer (took both off ethernet) and it still hung-up in initialization. Also, allowed to run overnight but never left initialization stage.

Update 2: To eliminate any communication issues, I installed the roon app on the mac mini. When I ran it, both my current core appeared as Ready (green dot) and the core on the mac mini itself still showed as initializing (red dot) and never ended that state.

Resolution: In attempting to resolve this stuck in initialization problem, I don’t recall how I actually got to this point, but the problem was that I had not logged out of the original core before trying to setup a second core. Roon on the mac mini indicated I had to use the current core or log out of it to use a new core (can’t have two cores running at once, obviously). Once I logged out, I was able to connect to the new core on the mac mini, which showed in the Ready state. Not sure what I did that caused Roon to require that logout decision, but that’s what fixed it.

6 posts were merged into an existing topic: RoonServer Stuck Initializing on new Mac Installation, Logs Showing Critical Exception [Ticket In]