Stuttering, dropout

The airplay router isn’t recommended for use by roon.

“Finally, we strongly recommend against using Apple network devices such as the Apple Airport Extreme and Airport Express (note: it’s fine to use the Airport Express as an Airplay device). To ensure the best performance, we recommend against using these devices.”

Thanks, Ged.

Does that recommendation still stand even though I am only using Airport it as a means to connect to the Internet and not to any ‘remote’ Roon Endpoint?

No home network which involves Roon. No Nucleus, no multi-room environment with wi–fi. One Core + all wired Endpoints.

The audio files which are exhibiting the phenomenon are on my local HD and the output to my stereo system etc all wired. No Airplay, no wi-fi?

Good to know for the future, though - if I’m understanding you correctly :slight_smile: .

I believe so. It’s still a router and Cady underpowered compared to modern devices.
Obviously I’m just another user lke you but quite often the symptoms you describe are down to a network glitch.
If you live in a market where you can buy things from a retailer with a good return policy, buy a new router and see if it cures the problem.

Thanks again, Ged. I appreciate your input. Something definitely to bookmark/remember if I ever expand; which I hope to if I can get rid of this stuttering/dropout!

Would you be as surprised as I would if I a router which only connects incoming Internet via Ethernet (not wi-fi) adversely affected all wired signal paths to devices local to my computer?

I wouldn’t be surprised at all, people post all the time that replacing their router solved issues.

Hmmm, this almost entirely defeats the purpose of having Roon. I recommend disabling SoundSource when you’re using Roon. In my experience, they are not compatible.

Your Roon core device must have a solid connection to the internet. Roon receives information over the internet to your Core. From the core, this information flows to your Roon control device to display the metadata for what your are listening to, even if local music files.

I know AT&T U-Verse is a very solid ISP. I have had U-Verse for years and it works very well with Roon. My internet service is 50/12, which is not nearly as high as some others, but it is rock solid. Do you have a U-Verse gateway? I think you must. Try plugging your Roon core device directly into your U-Verse gateway and see if that solves your problem. I have my Roon Nucleus connected by ethernet and it is flawless.

1 Like


Thanks so much. That looks like a real step forward :slight_smile: .

I see. Why? Is it because Roon needs (prefers/‘like’) to build its own Signal Path?

I’ll definitely give that a try. Thanks…

When you say ‘disabling’ SoundSource’, do you mean to Quit SoundSource altogether?
Or to leave SoundSource’s settings as ‘No Redirect’, please?

In both those cases I don’t get any sound from Roon.

In either case, I suspect you know that I have to make changes to Settings > Audio, which are like this:

But I don’t know which changes to make. And to which Device! Any help gratefully received… TIA!

Thanks, Jim!

Yes - tried attaching my iMac (and hence Roon Core) directly to the Gateway (new actually) via Ethernet. No difference so far.

Is it possible that loss of bandwidth (or similar) cases local files to flutter?

I don’t know, but it seems like a high percentage of problems with Roon turn out to be network related, even when simply playing local music files.

1 Like

Thanks, Jim… I’m getting to see that :slight_smile: !

I really need to understand Audio Devices and see which, where and how I should be controlling these in my case…

1 Like

Thanks again, @David_Snyder!

I have been experimenting and trying to make sense of Devices. This is what I have now:

But I’m not sure whether - in the case of my ParaSound - to use:

  1. Parasound
  2. System Output
  3. Built in Output

and what the implications for sound quality are… obviously I want the best I can get :slight_smile: .

And - for that matter - how to change Devices for output in Roon; they don’t seem clickable.

If I disable SoundSource by using the ‘No Redirect’ setting - and/or still use SoundSource for all my other sound sources except Roon (which I think is your advice, thanks), would I then use the macOS System Preference Sound pane?

And would the next step to be to fine tune the Device settings for 1, 2, or 3 in Roon’s Settings > Audio?

But which?

In this post I read that Built-in Output (3 above) results in better sound quality than System Output (2 above); but isn’t that using the Mac’s internal/low quality DAC?

Thanks to anyone who can help me through this little maze, please… I’m confused. But I know I can get there :slight_smile:

Choose output device (zone) by clicking in lower right corner…There, you will see all that you have enabled in Roon - Settings - Audio

1 Like

Thanks, Jim - I can see that…

Like this - Yes:


How do I actually switch from one device to another, though?

Are Devices synonymous with Zones?!

And - without SoundSource - what is the relationship with/role of macOS’ Sound > Output System Preferences and Roon’s Devices(/Zones), please?

Still not clear whether to use ‘Built in-’ or ‘System-’ output…

While something is playing, you can shift output from one device (zone) to another:

If you’re not playing anything, just choose the output (zone) you want to use. Click it.

1 Like

Bit of a Eureka moment there for me, Jim, thanks!

I think :slight_smile: !

Yes, I can now see how to move from one Audio Device (= Endpoint?) to another, playing and not playing.

But when I switch to certain of my zones, I see ‘Nothing Playing’.

Is that because I haven’t ever configured zones, and/or because zones are synonymous with devices - and I really do need to set up zones, even though I have everything in one room?

Secondly, does this way - internal to Roon - remove the need for me to control audio output by using macOS’ Sound > Output System Preferences?

I don’t know the answers to some of your questions. You need to go to Roon - Settings - Audio and enable any of your devices (zones) that you want to use. Basically, they are all the possible output devices that Roon is seeing, but each one needs to be enabled to be used as an output device.

Then, you can choose which device you want to play music to by clicking on the device in the lower right corner of the screen. You can play to multiple zones at the same time if you want to, but to play the same music to multiple zones, you would need to group them. That’s something I have never done.

You can control Roon from any connected device that has the Roon software or app installed. That includes a computer, iPhone, iPad, or Android device.

1 Like


You may not do - but you’ve moved me forward significantly. Thanks so much!

Yes, I have all devices enabled. But still not sure whether these are in ‘Zones’, or are themselves Zones.

For example, I now get the purple ‘star’ for all devices in my signal path - and can hear the difference :slight_smile:

What you directed also cuts out macOS’ Sound > Output System Preferences.

And - thanks to @David_Snyder’s advice, I’m not complicating things with SoundSource.

That makes me think I’m taking the shortest path from the FLAC files to my stereo system/headphones - which has to be what I want.


I would completely quit SoundSource when you’re using Roon. That works best in my situation, although “No Redirect” should, in theory, do the same thing.

1 Like

Each device is a zone. Normally, that would be an endpoint such as a receiver or some other device with speakers attached. For me, it an Oppo feeding a Bose system or a Raspberry Pi 4 feeding a Meridian Prime headphone amp, or another RPi4 feeding a Dragonfly Cobalt, etc. My Dell laptop also shows up as several different zones that I don’t totally understand the difference, but I never use any of them.

I don’t know what SoundSource is, but I would not use any other apps with Roon unless there is something about your system that requires that.

1 Like