Subwoofer and Airplay


I have Roon Core running on a 2019 iMac, controlled via an iPhone 12 Mini and an iPad Mini. My RPi hasn’t shown up yet, so I am currently using Airplay to send music to my Denon AVR-X3400H. The speakers in my 2.1 configuration are a pair of Klipsch RP-260F and a Rythmik L12 subwoofer.

I’ve noticed that when streaming to the Denon via Roon’s Airplay implementation, the receiver does not engage my subwoofer. This is extra strange, because it works on every other input—including using Airplay directly from the Music app, or anything else, for that matter. Spotify Connect also engages it appropriately.

I have my crossover set to 60Hz on all speakers, and the Denon should be using the LFE channel. Is this a known issue? What am I missing?

Thanks all. Love the software so far aside from this one little quirk.

To be clear, do you have your mains set to small speakers in the Denon and LFE+Main set for the subwoofer mode? Take a look specifically while the receiver is set to the Airplay playback (HEOS Music) source. JCR

1 Like

Thanks for replying!

I do have the speakers set to small. I was actually certain that would be the issue when I was checking it, but alas.

Is this set on your receiver?
from the web interface:
speakers →
I also use that sub. I use a rca splitter from my amp → low level inputs. Rythmik’s docs are pretty good on how to setup the sub for music, movies or a combo.

Yes, this is set correctly but it’s still not kicking on.

Hello Jonathan, welcome to the community.

I have not used the Airplay interface to my Denon receiver in a couple of years, and don’t recall for sure, but I suspect it is Roon not providing the .1 sub channel in the signal stream. Not sure why that is but I noticed that same issue with USB and Ethernet connections to my OPPO 205. I moved on to other device connections because I do like the addition of the sub channel.

I use the HDMI connection from NUC to Denon for multi channel playback and the .1 sub channel is there.

I’ve not had time to pull the manual for your 3400 so consider these generic comments about almost all receivers.

Most receivers have a “direct” or “pure direct” mode. This disables all room correction, EQ, etc. When these modes are enabled all 2-channel sources will play as 2-channel. That is, only L and R channels will get a signal. Nothing will go to LFE channel.

To get something to go to LFE then one of the “room correction” modes must be engaged. These modes are usually source dependent. It would make sense that, by default, Airplay may be in one of the direct modes and you need to change it to a room correction mode. Sometimes this is as simple as cycling direct on/off. Sometimes you have to select one of the “virtual” surround modes.

This was the culprit. I’m annoyed I hadn’t thought of it. Haha.

Thank you all for the help.

1 Like