Support for DSD128/PCM384

Hi guys,
I’d like to know if there are any plans to add support for higher sample rates that the current PCM384 and DSD64 i’m seeing with my Sabre 9038Q2M-based Raspberry Pi HAT.
It’s one of these:

It uses the standard “Hifiberry DAC” driver and with RoPieee i get PCM384/DSD64.
(If i use DietPi i get PCM192/DSD64)

I’m not sure if @spockfish gets any needed info from it, but i did “Send feedback”:

These HAT’s are not the most easy to support.
There aren’t any drivers, so it uses the Hifiberry DAC driver.
The Hifiberry DAC supports up to 192K so…

Thanks for your input Harry!

You have obviously provided support for PCM384 today?
I dont know how this works, but would it be possible to configure max rates for DSD and PCM to non-standard values?
(I mean by adjusting a cfg-file or something over SSH)

Hi. RoPieee does support Audiophonics I-SABRE ES9028Q2M/ES9038Q2M DAC driver.

This DAC supports 384kHz / 32bit, PCM 16/24/32Bit Auto Switch, DSD 64/128

But, in Roon, I still can’t get 32 bits, no more than 192 kHz, and in the Roon path, DSD128 is converted to DSD64 (in DoP mode).

In Roon, Audiophonics is not supported, so I can’t identify the device (may be it’s the problem)…

Is there a way to get full support of this I2S DAC wich is very nice by the way ?

Thks for help !!

Here, what I see (if I click on "indentify this device, Audiophonics doesn’t appear)

Any news on this? I have the very same HAT DAC so hoping someone can shade some light into this


Its properly detected after I swapped from RPi 3 B+ to RPi 4 4GB
I having some strange issues at the moment and trying to figure it out

Thanks @rikardo1979
But I can’t change my RPi 3 right now because it’s part of my Audiophonics RaspDAC.
So I hope it will be fixed

Still not news about this issue ?

@spockfish Hi. This issue seems to be solved with the RPi4… RPi4 issue.
Do you think it can be with the RPi3 or I have to deal with until I change to RPi4 ?
Best regards

I’m not sure what you’re referring to.

This issue talks about DSD128, while the other issue is about volume.

Anyhow, if you’re using the Audiophonics I would advice to go for the PI 4, just because over there we can at least use their merged driver. But no guarantees; this hardware is difficult to support.

I was referring to the fact that, on Rpi4, the Audiophonics Hat DAC seems correctly supported in Roon. What is shown in this topic, although it is about another issue when Rpi4 is used.

Ok. I’ll see how I can change my RPi 3b+ by a 4 in ´my RaspDAC.

I have a solution for you if you still have it with RPi 3 B+ :wink:
To enable full capacity of your Audiophonics HAT you have to choose and enable Hifiberry DAC as an audio option
It still going to show as snd_rpi_hifiberry_dac in Roon but you would be able to enable the 384kHz 32bit :wink:

Not sure if is it going to work straight after you set this from within Ropieee GUI go to /boot/config.txt and add following lines


Let me know if this working for you

Hi @rikardo1979
Thanks for your reply.

I’ve tried what you suggested.
Yes it activates 384 kHz / 32 bits… but it doesn’t support DSD without conversion.

Here with Dsd64 reading…

With Audiophonics driver I can read Dsd64 without any conversion on the path. Just, conversion is needed for DSD128.

So, it’s better with Audiophonics driver because, in PCM, I don’t have files above 192 kHz/24 bits.
But I Do have Dsd64 and Dsd128.

Here, a DSD64 with Audiophonics drivers

Hi @Eric_Malaussena
This is what I have here with these settings. One file is DSD128 another is DSD64

Hi @rikardo1979
I got it ! I had forgotten to select DoP once in Hifiberry DAC mode
Thanks a lot !! :pray:

So… the Audiophonics devices are really difficult. I almost made a remark on the website that support from my side is nothing more then a ‘best effort’.

Reading this I’m wondering if it would be wise to just select the hifiberry DAC driver ‘under the hood’ when you select the Audiophonics.

Any thoughts? @Eric_Malaussena and @rikardo1979 are you missing out on functionality with the hifiberry driver?


Hi @spockfish
I test it since today. Actually it works just fine.
But don’t know exactly what to check to say everything is ok.
And I have to find vey high res pcm files to check 384 kHz / 32 bits.
I will reply again then

1 Like

@Eric_Malaussena glad you got it sorted

@spockfish to be honest I am not sure yet. It seems to be working fine with this driver.

But I still trying to understand and troubleshoot why the proper I-Sabre won’t load and work.
It does work with RPi 4 but I experienced that intermittent sound issue which I couldn’t find the cause of

I will try to read and play with it more, but I have not much time lately.

Will report back again if I discover something

1 Like

I found a 352.8 kHz/24 bits file…
I don’t understand why it is converted to 384 kHz on the path .

What I see :