Support for Wifi RTL8812BU?

First of all, thank you for RoPieee! It works great!

Are Wifi Dongles with RTL8812BU also supported with Allo USBridge Signature?

If not, are there plans to support it?

Looks like the RTL8812AU will be replaced in newer products.



The Realtek hardware is difficult to support because of proper driver support… However, I’ve patched RoPieee’s kernel with the 8812AU driver and are in the works of adding the 8192EU driver.

This also needs to happen to the 8812BU driver.

So… if someone gets me a device I’ll look into it :wink:

Hi Harry,

I have a USB 3.0 wifi dongle coming with RTL8812BU chipset. I’m running latest Ropieee on RPI4 with USB audio (no hat). Anything I should know to implement it? Reconfigure wifi?

Thanks in advance,


Curious: The RPi4 has built-in 802.11ac Wi-Fi, so what is your use case for adding a USB Wi-Fi dongle?

Reconfigure is enough.
Keep in mind, that although the driver for this chipset is included, there are no guarantees.

Hi, the Pi is in the all popular Flirc case located downstairs from the router. While hooked up via USB to an Oppo HA-1 headphone amp / DAC it drops out periodically. I get “Tidal is loading slowly” or whatever that message is. I also tried just music from my NAS with dropouts. I have not gone through the hassle of arranging the setup over Ethernet, so my purchase of the dongle is troubleshooting (hoping for solution at same time).

Thanks for asking.

Ok thanks for the response.

Well, the dongle lights up and the wifi connection details indicate external, but after approx 10 mins the dongle appears to loose power along with connection to the router. I see the TP-Link Archer T4U is called out as being supported in 2.486. I will return this one and get on of those to see how that works.

I am using the CanaKit 3.5A Raspberry Pi 4 Power Supply (USB-C).

Can you do 2 things?

First switch to the beta channel (you can do that in the ‘advanced’ tab).
Second, can you send me feedback (also from the advanced tab) so I can have a look?


Logs have been sent to RoPieee HQ with unique identifier f9fab12b6f7e9292

Ok, you switched to beta, but did not update.

If you go back in the web interface there will be a message stating that an update is available. You need to pull that one in.

I did attempt the upgrade last night, but it did not go. When I clicked on the network tab after the upgrade it just gets hung up and continues to display the subscreen “wifi - scan for networks” with a spinning rectangle. I sent feedback after the upgrade and power cycle before clicking on network tab: a74c620ff3bec6e7.

It identifies as 2.524 [beta].

So… what is exactly not working? Because you have a working wireless interface.

It might be that only the web interface is not working…

Is playing audio (Roon) working?

When I connect it to the DAC via USB it shows up in Roon and I can play to it, but it’s spotty and drops out. A song plays for about 45 seconds and sputters then drops with the message Tidal is loading slowly. Same result with music stored on NAS. The WiFI signal is fine where the PI is located. My Tablet control point works just fine next to it. Red book files seem to play a bit longer before dropping than 24 bit ones do.

Maybe it’s an issue with the USB interface. Is that correct that I should only be able to see it in Roon when the USB DAC is connected to it? What if my USB DAC requires a driver? I had to load it on a PC before to use it.

I relocated the PI and DAC closer to the wifi router and it appears to be stable so far. Though the web interface becomes unusable if i click on the network tab - cannot reconnect to it over ip unless I power cycle it. But during this time, everything works just fin when it’s closer to the router. Apparently I just had it in a bad place and will experiment with different locations. Should I go back to the stable channel?

Thanks for your time, much appreciated!

Hi @Daniel_Steixner,

Good to hear. I need to figure out why the scanning is taking so long (and not even coming back) but at least you can enjoy the music :wink:


Apologies for the necro post… I found this thread when I was having spotty wifi with my RPI4/Flirc case combo. I grabbed one of [these] and all is well. (