Switching Core PC & Clarification on How Remotes Work [Remote Connection]

I just recently switch CORE’s in my setup. Not sure if this is the ROON way, but I have had no issues so far. Note, both machines have the same OS. I am using Windows.

Start: PC1 - Core, connected to End Point (DAC); PC2 - New machine.

PC2 - Loaded Roon. Did not open application.

PC1 - Copied the ROON folder (appdata/local/roon) to PC2. Renamed Roon to OLD-ROON.on PC1. UNINSTALL Roon on PC1. Delete OLD-ROON (only AFTER you know the new Core is working)

PC2 - Open Roon, de-authorized PC1, PC2 is now the CORE and the DB is all there (with your fixes/changes) so you do not have to IMPORT or fix up albums/songs again.

PC1 - Install Roon, Open Roon, Connect to PC2 (Core)

PC1 is now a Remote Roon PC, and PC2 is the new Roon Core.

If the two boxes were not the same “family” OS then this will not work IMO. You would just have to import again.

A few days ago moved Cores on my Mac system per @Robbbby above. Tiny lingering issue is the former Core, now Remote, is somehow still hanging onto a music folder preference no longer assigned to it or the new Core. The folder does not show up in storage settings on either machine nor is its music available for browsing. However, when trying to eject this external USB drive from the now Remote, my System tells me the drive’s in use by Roon. So I quit Roon on the Remote machine, eject the drive, and relaunch Roon. I’ve closed and relaunched this Roon Remote install several times with and without this drive mounted, but some preference seems to be hanging on somewhere? No biggie, but have yet to sort it out.

@bebop57 – this sounds like a bug. We’ll look into it, but I have an idea of what the issue might be.

As a workaround for the moment: If this is going to be your remote going forward and you’re not planning on using it as a Core again, you can try doing a full uninstall and I’m sure we’ll stop talking to that drive. Just reinstall and run as a remote and you should be good.

Thanks. Should have gotten around to that. Too much fun finding new music. And for anyone reinstalling, remember to delete the Roon folder in your …/Users/username/Library/ folder along with Roon music folder (path displayed in Roon>>Settings>>Storage, default to …/Users/username/Music) along with the application itself.

I tried Roon on a laptop under Windows 7 for about a week. I then wanted to move it to my HTPC (core i7 Ivy Bridge in HDPLEX fanless chassis running Windows 8.1). I followed the above procedure but it did not play out as described. (is it because I am still in trial mode?) I logged into my Roon account but was never prompted to unauthorize the laptop. Now the iPad remote app does not see the HTPC but still sees the laptop when running Roon. When non running Roon on the laptop the iPad app finds nothing, even when I enter the IP address for the HTPC… Am I going to be automatically billed for two licenses? Shouldn’t the account page have information somewhere as to what machines are licensed as “core”? If I understand your usage correctly I still want the laptop to be a “remote” machine.

Another weird thing that happened while installing on the HTPC: I installed under an administrator account as is customary then switched to a normal user without password account I would normally be running. No sign of Roon anywhere, no launcher, no executable, search for “Roon” or “roon” turned up nothing. I ended up reinstalling under the normal user account (I probably did have to give an administrator password in order to complete the second installation).

Is there a glossary somewhere defining your usage of “core”, “remote”, “endpoint”, “private zone”, “Roon speaker”, etc.? Just so we can all be on the same page?

Aside for those issues and a few other minor points of confusion typical of any new software system everything is going swimmingly. Very impressive product.

Hi David,

Trial mode is not crippled in any way.

If you don’t care about retaining your existing database, then the simplest thing to do is:

  • completely uninstall Roon on the laptop and the HTPC;
  • reboot the HTPC and install Roon as Core;
  • configure the HTPC to accept Remote connections in Settings
  • reboot the laptop and install Roon as a Remote
  • enter the IP address for the HTPC into the iPad app

If you do want to retain your existing database then:

  • backup your existing laptop database (C:\Users[Account Name]\App Data\Local\Roon\Database)
  • completely uninstall Roon on laptop and HTPC;
  • reboot the HTPC and install Roon as Core;
  • copy the backup of your laptop database over the HTPC database;
  • configure the HTPC to accept Remote connections in Settings;
  • reboot the laptop and install Roon as a Remote
  • enter the IP address for the HTPC into the iPad app

So far as I am aware you will not be automatically billed for two licences at the end of your trial period. @mike may be able to clarify.

In my experience the Roon team quickly sort out any issues arising from automatic billing relating to even one licence and I would expect them to be equally responsive where two are concerned. If you have any concerns at all about billing then a quick email or message to @mike or @danny will get it sorted.

Settings/General/Library shows which machine is Core.

There is a FAQ on the main Roon Labs page and in the Support section of this forum. One way to find out what the various terms mean is to enter them into the search engine and browse the posts, but this is my attempt at a glossary:

Core - A Roon installation that is not a Remote. You can only have one Core per licence but you can have unlimited Remotes. The machine on which the Core is installed does all the audio processing in Roon. All Remotes configure the Core.

Remote - A Roon installation that controls and configures a Core. The Remote will only form part of the audio path if output is directed to a Private Zone on the Remote.

Endpoint - A device to which Roon can send audio. These are configured as Zones.

Currently you can send output to the following Endpoints:

  • any device connected to the Core that is recognised by the Core operating system, controlled from the Core or any Remote;
  • any device recognised as a Network Zone (currently only Airplay and Meridian supported), controlled from the Core or any Remote. This will be expanded when RoonSpeakers arrives;
  • any device connected to a Remote and recognised as a Private Zone by the Remote operating system, controlled only from the connected Remote. This will be expanded to enable control from the Core and other Remotes when RoonSpeakers arrives.

These posts contain most of the publicly available information about RoonSpeakers and Private Zones:

Hope that helps !


1 Like

Thanks for the reply. I followed the first set of instructions. No
need to preserve the database, having learned more about how Roon works I wanted to set things up somewhat differently. After the
reinstallation, iPad Roon remote sees the HTPC but fails to
connect. It flashes “last seen 10 sec. ago”, “connecting”, but in
the end it always fails. I double checked Roon is set to accept
remote connections, and I lowered the Windows firewall for both
public and private networks, still no joy. I also tried deleting
and reinstalling the remote app on the iPad, same results. I assume
under normal conditions, if the Windows 8.1 firewall were blocking
your app it would notify me and give me an opportunity to add it to
the exception list, which is ultimately what I would want to do. So
it’s probably not the firewall. Anything else I could try?

Hi David,

Sometimes network problems can be resolved by using a fixed IP address for the Core (HTPC).

If you can post a screenshot of the storage tab on your Core that may help. Let’s ask @mike or @danny to look in on the thread again and see if they can help.

There was also a bug introduced in v1.1 related to this… I think @mike is getting a new build out very shortly, but I could be mistaken about the schedule.

Tried assigning a static IP, still NG (forgot what a PITA that Asus router software is, no wonder people hack it with Tomato). I took a screen shot of core’s storage tab (not sure why you wanted that) and of the error message on the iPad (there must be some nifty app for capturing screen shots on the iPad but I don’t know or have it so photo will have to do). Not sure how to upload images to this forum though.

I was working with the Roon Dev’s for 4 hours last night, through to 0100hrs, working on this problem, which may be similar to yours.
Several bugs found, which will apparently be dealt with very soon.
Contact @mike and @vova for more details.

Don’t worry about the screenshot at this stage David. Sounds like a known issue that’s getting fixed.

The storage tab shows the paths to organised and watched folders. Sometimes that helps understand connection problems.

You can upload images to the forum using the icon with the up arrow in the editor.

I hope this can be fixed for you shortly.

Yes I see that now, before I start typing. Would that known issue be with the Roon core program or the tablet app?

Perhaps. But I’m still getting “connection failed” after turning remote access off then on.

I reported this on the 27th August. Frustration is not the word…
But as I clearly wrote above - contact the Roon team if you want more information - the bugs will apparently be dealt with soon (note emphasis).

We have a release in testing right now with fixes for a few tricky bugs related to this issue.

@rolski was incredibly patient and helpful, and we finally were able to see this issue after weeks trying to reproduce internally without success.

Hoping to get the release live in the next few days guys – as always, thanks for your patience.

I tried barking up another wrong tree today (in case your new release doesn’t fix my problem): it occurred to me maybe the Windows 8 security model doesn’t like programs run by non-administrators accepting outside connections. I tried running as administrator and I tried deleting from the normal user account and installing under the administrator account. Still no good.

That leads me to ask, though, why the heck you’re installing your executable under the logged in user’s app data directory, which is normally hidden, instead of in the programs directories. It confused me the first time I ran the installation under an administrator account, as is customary, then switched to the normal user account and couldn’t find the program anywhere! I understand there may be several people using the same machine, each with their own music collection, but isn’t that what profiles are for? Also, presumably if you switched users instead of logging out you could have several instances of Roon running on the same machine, but only one could be core. I ruled that possibility out too.

For now I moved my core back to the Windows 7 laptop, which still accepts remote connections fine… I’ll be happy to test your release when it comes out.

For many years apps that are meant to be local to user (and updatable by user without UAC prompts) belong in LocalAppData. For years, Chrome used to install there, as well any applications using the Microsoft ClickOnce mechanism.

By the way, this bug has been fixed and just needs to be rolled out. The issue will be very difficult to work around :frowning: Waiting for a build will help save your sanity.

Hello @Leporello are you still having the connectivity issue ? Yesterday we’ve released a new build, try to update your client. If the issue persists feel free to ping me and I’ll try to help you.


The behavior is more or less the same. The remote searches for “libraries”. If I diddle with the core machine (perhaps restart Roon or toggle “accept connections” off and on) it sees the core machine but still fails to connect.

But your terminology is confusing. You say update my “client”. I updated the core machine, but there doesn’t seem to be an update for the iPad remote app.

I can try setting up the laptop again as remote with the new build–previously it had behaved the same as the iPad–but that still doesn’t get me to where I want to be.

Is there a way to tell when there is a new build other than downloading and installing it? The Windows file is just called “RoonInstaller.exe”. The creation date gets set to the time of download. I can double check I didn’t install a previously downloaded version.

If I knew for a fact installing Windows 7 on the HTPC would fix the problem I would buy a copy. I dislike 8.1. Better still, Ubuntu desktop. I know the consensus among Linux lovers seems to be to concentrate on headless server for NAS and Raspberry Pi-like endpoints–both of which interest me also-- but I would far rather use Linux than Windows for my core machine, for any number of reasons. I realize this would come with a whole new debugging cycle.