Switching daily between Roon core on work vs home computer?

Yes to all !
:slight_smile:

@alec_eiffel – Great, thank you!

Except that I am a TIDAL subscriber instead of Qobuz, your use case is mine, one core at home, the other at work. The license swap process is super fast, just one click.

@alec_eiffel – Ah, good to know, thanks. BTW, do you know whether the Core being disconnected has to have an active internet connection when it’s being disconnected…?

No need as long as you have an active internet connection on the new Core you are connecting to. The other core doesn’t need to be disconnected or shut down by the way.

Excellent – I hope to soon be able to enjoy Roon at work for the first time – thanks!

Thought I’d give an update on this, in case anyone is interested – I have been able to get this working. So I am now able to listen to Roon either at work or at home, by switching my single subscription from the core running on one computer to the other. It feels really good to be able to use Roon at work as well now, so many thanks to @wizardofoz and @alec_eiffel

The only thing I’ve run into is that the switching process for me is a bit less smooth than I had hoped. When I start the core that I want to switch the license to (“Core A”), the message that I need to unauthorize the other core (“Core B”), with the option to unauthorize Core B, doesn’t always come up – I often just get a message that I can’t use Core A because I only have one license. This happens whether or not I had “disconnected” Core B before starting Core A. I then need to quit and then restart Core A to get the message containing the unauthorization option for Core B. And then, even when Core A does come up in authorized mode, the “syncing” circle is frequently missing, and replaced by an attention icon, which says something to the effect that “syncing of metadata won’t happen because an update is needed” (no update to Roon is actually needed). So then if that happens, I have to quit and restart Core A again. And then Core A works perfectly.

But (so far), these two-or-three restarts of Core A are seeming like a relatively small inconvenience as compared to the value of having full Roon at work!

Suggest you open a #support thread on this issue

@wizardofoz – thanks, will try that.

I am same case as you, one core at home and one core at office, But not everyone have own room and own space to place own machine in office, or have permission to install own software on office machine.

I wish and I prefer to integrate into one core for two locations and mobile on the go, then I can invest the best core and resources one one core machine, Instead of managing two cores two databases and using double NAS storage and core machine for same set of Music, and do the edit twice for unidentified album, I hope the long awaiting is not Version 1.8 but 2.0 releases can deliver this feature.

Core Machine (Operating system/System info/Roon build number)
Core Machine A: Acer Laptop running Windows 10; Roon Version 1.7 (build 610) stable (64 bit) for Windows

Core Machine B: 2014 iMac running Mac OS 10.13; Roon Version 1.7 (build 610) stable (64 bit) for Mac

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
For Core Machine A: Wifi

For Core Machine B: Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

On both Cores: USB connection to HRT Music Streamer II+ DAC
On both Cores: all music content files on a 5 TB WD portable external disk

Description Of Issue

Can you please see the thread I started at:


Thanks to the Community help in that thread, I have figured out how to do the switching. However, as I note at the end of that thread, I often have some glitches with the actual switching – they get resolved by two-three restarts of Roon, but it would be great if it was smoother:

@support, can you help with this last part, please? – thanks in advance!

Hi @otinkyad,

I’ve merged your two posts and moved the whole thread to #support so that we can have all the information in one place.

Can you please share two screenshots of what your authorization screen looks like, one screenshot with expected behavior of what it should look like and one that describes the issue above?

If you can also note the time + date you capture those screenshots, it would be helpful in case we need to look further into diagnostics.

Hello @noris – thanks for the reply. Sorry it took me a while to get the screenshots, as I hadn’t actually switched cores in a couple of days – hadn’t had a chance to listen to music on home core in the evening – oh, the horror!

I’ve attached more than two screenshots, to document the TWO issues that I mentioned in my last post above: (1) Roon not asking to unauthorize the other core, and (2) the red attention triangle which when clicked shows the “metadata improver halted, Roon needs an update” message.

  1. Start Roon home core (on Windows 10 laptop), 7:27 pm 20200903 (work core was shut down when leaving work). Home core starts with no request to unauthorize work core. But notice red attention triangle near top right:

  2. Clicking red triangle brings up this message [but Roon version is the latest]:

  3. Check Settings to see if there’s an Unauthorize button there – there isn’t:

  4. Log out of Roon, restart Roon. Now the Unauthorize screen comes up:

  5. After clicking Unauthorize, Roon home core starts up, but comes up with the red attention button again:

  6. After quitting Roon again and starting Roon again, Roon home core finally comes up “clean”, 7:40 pm:

  7. And then this morning, start Roon work core (on iMac), 8:56 am 20200904 (home core was shut down at night, Windows 10 laptop powered down). Work core starts up as it should, with Unauthorize screen:

  8. On clicking Unauthorize, Roon work core starts up correctly – no red attention triangle:

Although this time, the work core worked as expected, there have been a number of times that it has had similar issues to the ones described above for the home core.

Please let me know if you need additional information – thanks in advance for any help!

1 Like

Have you tried leaving Roon up in both locations, the switch over might go smoother if both installs were up and available to the authorization server.

Hello @Rugby – thanks for the thought. Yes, I’m pretty sure I had tried that without consistently solving the problem. I could try again, I guess, to troubleshoot. I wouldn’t want to be leaving the home core laptop on all day regularly, but I guess trying your suggestion again systematically could at least help isolate the cirumstances that do or do not lead to the issue – thanks.

Yes, it was just a try it as a test suggestion, not, set it up that way permanently.

That being said, I remote into home pc running Roon, and have the audio routed via the remote software to my office local speakers. Not high res, but, I don’t have to bother with multiple setups.

@Rugby – thanks again.

I haven’t considered remote-ing into the home machine because of concerns about security + limited confidence in my ability to make things secure. I think this would require poking a hole in my home core Windows 10 laptop firewall (and maybe router firewall?) and having everything run all day with that hole open – plus, using internet bandwidth all day at home, I think? And not to open up a can of worms, but my impression is that security isn’t prioritized in the Roon architecture either (e.g. any mobile device running Roon remote on the same network can seize control of Roon without even one-time device authorization needed, which to me is lower security than I’m comfortable with).

Maybe I should look into this some more, though. Any pointers on where to start to make a Windows 10 laptop secure for remote access of this kind…? – thanks –

Thanks for sending those screenshots over @otinkyad! I plan to discuss your findings with QA, please don’t start opening up firewalls just yet.

Hello @noris – thanks for taking this up with QA.

I have two slight updates:

First, I did try what @Rugby suggested, for a few days – leaving both cores running. It seemed to make things a little bit smoother. But I still ran into similar issues. On the work core, although it would come up with the “Unauthorize” screen, after clicking to Unauthorize the home core, the work core would sometimes still come up with the attention triangle and “metadata improver halted” message, requiring a restart to come up “clean”. And on the home core, I had some odd behavior, as shown in the screen shot below, claiming I am entitled to authorize 0 devices:

My other update is that I discontinued the practice of leaving both cores on, and reverted to shutting down the home core (and laptop) at night, and shutting down the work core when leaving work in the evening. The glitches may have gone back up a bit (same as reported in my previous post with all the screenshots), but it is not feeling overwhelmingly onerous to deal with them.

I’d certainly appreciate any insights QA has, though. Thanks again.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.