Synology can't play AAC music, reboot needed

Roon Core Machine

Synology DSM 7.1-42661 Update 2, iMac (Retina 5K, 27-inch, 2019) 3 GHz 6-Core Intel Core i5 16 GB 2667 MHz DDR4 Monterey 12.4

Networking Gear & Setup Details

Fritzbox SSID 6690 ME - Ethernet to the NAS Synology DS218+ DSM 7.1-42661 Update 2, WiFi to Auralic Polaris

Connected Audio Devices

Auralic Polaris Streaming with WiFi

Number of Tracks in Library

29,000 tracks

Description of Issue

Roon is only playing Tidal music - the music from the server is visible but don’t play …
In Roon I can see my music, it is all imported. But I can only play music from Tidal. Own music won’t start. After that it is also not possible to play Tidal until I have restarted Roonserver on my NAS.

1 Like

Which is the Roon core the NAS or the iMac ?

The core is the NAS
Version 20220216 by Christopher Rieke

Maybe ffmpeg issue

Strange thing: I wanted to play music from my own collection. Result = freeze! And an allert in my mailbox:

New sign in detected

A device from Schaffhausen, Schaffhausen, Switzerland just signed in to your Roon account. If this was you, you don’t need to do anything.

Note: Your location may be inaccurate since it was estimated using your IP address.

If this doesn’t sound right, please let us know by replying to this email, or visit this page to reset your password.

??? what does that mean?

Missing ffmpeg codec.

Hi Mike
the problem still exists … any idea what is wrong with my config?

Have you done basic troubleshooting like rebooting everything including the NAS?

shure - and every time I try to start an own track, I have to reboot my NAS

Hi @Christoph_Buergin ,

Can you please confirm if local FLAC files also have this issue? Or is it limited to AAC files? If you don’t have any FLAC files to try, you can download a few from the 2L Test Bench (right-click on the file size → save as).

Hi noris
yes, I imported a FLAC file, put it in my music folder, and roon plaed the track.
Then I chanched to an old file in my catalog, and roon stopped. I had to stop roon on my server and reboot it. Then I could play music again.

Hi @Christoph_Buergin ,

Thanks for confirming that. This sounds like ffmpeg on your Synology is not working as expected, please see the following instructions:

Hope this helps!

2 Likes

Thank you so much noris!
I installed the ffmpeg-git-i686-static on my Synology and yesssssss, my music is now playing on ROON.
Not to forgett to donate some money to johnvansickle.com.
Thanks again and you are great!

2 Likes