Synology Core Port forwarding setup issues

I have another issue and wondering if it’s unique to running Roon on a Synology:

I cannot get Roon ARC to connect to my Roon Core when off my wifi.

I’ve ensured my router is running PnP.
I’ve added port forwarding matching the same port number as what is in the Roon app’s Settings/ARC setup area.
I’ve stopped and restarted PnP.

The IP address on the router for the PnP (and port forwarding) is my Synology’s IP address.
There is nothing in the Synology’s Package Manger area for the Roon to configure port forwarding or PnP.

What am I missing?

I am also running RoonOnNAS on a Synology and ARC works like a breeze. No perf problems neither.
Firstly I would do either PnP or manual port forwarding. Doing both in parallel does not help with analysis. And you are right it’s not in the package where to configure such. What’s the error message you see in Roon’s ARC settings?
Another culprit might be an additional firewall running on the Synology. If there is one switch it off at least for testing.

Here’s the error I’m getting.

I’ve switched off port forwarding now. uPnP is on auto.
Firewall on Synology is not enabled.

You have either have two routers connected to each other, or, your ISP service is CGNAT. Since, this is a Port Forwarding question, I am moving the appropriate posts to a new thread in that support section.

Please provide the additional information so that support can help resolve your port forwarding issue.

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

The diagnostics you’ve provided suggest there is a redundant layer of network address translation preventing port forwarding.

This can either be at the local-network level (commonly as a result of two routers), or at the level of your service provider (in the form of carrier-grade NAT).

If your setup involves an ISP-provided gateway (modem/router combination) and your own third-party router:

  • In the web administration interface of the ISP-provided gateway (modem/router combination), enable Bridge Mode or equivalent, where the ISP-provided gateway does not have DHCP routing enabled.

  • Alternatively, if you have already created a manual port forwarding rule in your 3rd party router, you can add an additional rule to forward the port through the ISP/second router.

If you only have one router in your setup or your modem is already in Bridge mode, please take a look through our list of known router and internet service provider solutions, as other users may have already encountered the same situation: ISPs and Routers: List of Known Solutions and Workarounds

You can reach out directly to your service provider to ask if they support port forwarding; this question will often enough to prompt them to explain whether or not the carrier-grade NAT they’ve implemented can function with ARC.

More specifically, you can pass along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

If you’re unable to locate an existing solution in our #support:port-forwarding-resources subcategory, please reach out to the Roon support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Hey @Joe_Figueiredo,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

Following up on this thread, were you able to get Arc and port forwarding sorted out? @Rugby has laid out excellent next steps in the process if so.

I’ll be monitoring this thread for your reply :+1: