Synology folder name from migrated NAS

My Roon daily-driver is a ROCK but thought I’d give Roon a go on my new Synology 1520+. I recently used the Synology migration tool to copy all my shares and config from my 416play, and the 416 is now decomissioned. When setting up the local folders for Roon on the 1520+, I was surprised to see reference to the 416play in the path name. I can’t find anything in my 1520 DSM control panel that indicates heritage 416play naming on anything. Can anyone advise why I might be seeing this?

By the way, even though I’m just using 5400rpm HDDs in my 1520, Roon is running perfectly, experience with my iPad control point is just fine.


Hi @ACvitus,
The model name is read from a file of your diskstation config folder (/etc/synoinfo.conf).
As the name did not change with your new model, it either seems something went wrong during migration process of your diskstation data or the synoinfo.conf also gets migrated to the new model, so Roon still reads the old diskstation name.
If you are familiar with ssh and could verify the content of the synoinfo.conf file mentioned above?

thanks for the reply. It looks like the migration assistant utility copied the name from the upnp section. I’m not currently running Media Server on the 1520, the service had been disabled on the 416 but had been used previously, so perhaps that’s why.


At the top of the synoinfo file the model number is correct:


I can’t find a way to change the upnp model name via DSM’s web interface, I guess I could fix this manually.

1 Like

Thanks for checking. Yes, the synoinfo.conf seems to be migrated from the old diskstation then. I was not aware of that and suggested a change to read the device name from “/proc/sys/kernel/syno_hw_version” instead. (you should get the correct value when issuing the command cat /proc/sys/kernel/syno_hw_version ).
But even though the value is currently not accurate in the file browser, it should not cause any issues (afaik), as the model name is not used in any file paths.

I wonder if this indicates a minor bug in the Syno migration utility.

The cat command you provided correctly identifies the NAS as “DS1520+”. Out of curiosity I activated the Syno media server and looked for how it was advertised on my network, and it was identified by its network name “DS1520”, which is an editable attribute within DSM. But the model name in synoinfo.conf remained stuck on 416play. I edited it manually and now the 416 reference is gone in Roon. However, I would suggest that the path shown in Roon seems to be redundant in that the machine name is mentioned twice?


by the way, many thanks in helping me fix this, although there was no issue with functionality, it bugged me to understand why. Also, great work to have a Roon build for Synology, I will see how well the 1520+ copes, so far so good. I have a spare bay into which I could fit an SSD, will see how essential that turns out to be.

It is mentioned twice in your case, as your Diskstation apparently has DS1520 as its hostname.
Otherwise these names can be different. Your diskstation’s hostname could also be something like “MyMusicArchive”.
The correct upnpmodelname should be identical to the one given at /proc/sys/kernel/syno_hw_version, so in your case, you are missing the “+” right now.

I have no clue, if this is a Synology bug or if there might be a reason for this. Until now I assumed, the synoinfo.conf will always show the correct value.

yes, my server name is “DS1520” with no “+”, and that is the value I’ve now given to upnpmodelname in synoinfo.conf. Odd that this attribute is not editable within DSM, at least that I’ve been able to find.

No problem. Just wanted to point out that the default value in synoinfo.conf would have included the “+” (as you have the plus model). But this is just cosmetics… :wink:

could you please tell me the command line to change the name of the synology NAS? I have the exact problem as yours.

  1. In your Synology Control Panel, make sure that SSH Service is enabled in Terminal & SNMP.

  2. In a terminal that supports SSH, issue a command like this:

    ssh -2 {AdminName}@{HostnameOrIPAddress} -p{portNumnerSpecifiedInYourControlPanel}

    Like this:

    ssh -2 admin@ -p22

    When prompted, enter the appropriate password for that admin account.

  1. Follow these commands:

    a) cd /etc
    b) sudo cp synoinfo.conf OLD.synoinfo.conf (when prompted, enter your admin password; this creates a backup of the file in case you make a mistake)
    c) sudo vim synoinfo.conf (or use whatever text editor you prefer)
    - Search for the line that includes “upnpmodelname”
    - Edit the value and save the file.

  2. Reboot your NAS.

1 Like

Thank you very much. That did the trick.
To save the file in vim I had to press Esc key, type :w and hit Enter key
Once again thank you very much.

That’s correct; standard VI/VIM practice!