Synology (roon core) -> USB -> DAC / but limited output bitrate

Hello all, I’m a relatively new audiophile and I’m trying to play hi-rez files directly from my roon core (running on a synology DS918+) via USB connected to my DAC (i.e. the USB input on my Cambridge Audio CXA80), thus bypassing any streamer. It works ok out of the box, however the CXA DAC is supposed to support 192 kHz, yet Roon downsamples the file to 96 kHz over the usb connection for some reason and I’m wondering why not 192…

The same file playing on my hifiberry plays fine at 192 khz without being resampled.

My suspicions would be:

  1. I misconfigured something, and I just need to set a parameter somewhere in roon (if so, what?)
  2. I need to change some config file in the synology OS telling him that the ALSA soundcard actually supports 192, nut just 96 and it’ll work perfectly (or install some specific drivers/config files for this soundcard). If so, any link/infos?
  3. playing via USB on a synology is limited to 96 khz regardless of the DAC (just because of USB and how roon streams its data), because of some reason.

Anyone having this setup and/or tried to solve this? Mostly out of curiosity than anything else.

p.s. I’m planning to buy a proper streamer in the next few months, so this setup is only intermediate. I obviously don’t expect to do justice to 192khz files by playing them via the usb port of a nas :wink:

I suspect the linux OS in your NAS only supports USB audio 1.0 which is restricted to 24/96

interesting, thanks! So this is essentially an OS configuration, not hardware, or is it? If it’s only software, I should be able to simply install a audio class 2 driver (according to here Mac OS supports both, so I’d assume same should be true with the synology nas). Any hints in how this could be done (seems like audio station can play 192 files, hence wondering how roon bridge playing locally could leverage the same driver)?

You need to get an external endpoint to connect your DAC to realize its full potential. Synology does not provide many USB kernel drivers, and never will; their focus is on being a NAS. And kernel drivers are not something you easily hack in on your own.

This doesn’t have to be super expensive, either. A Raspberry Pi with a USB Audio HAT can be had for pretty cheap. And, of course, the sky’s the limit depending on how willing you are to be snookered by the snakeoil salesmen… :smile:

If you are hell bent on going usb out from your nas then you need to talk to Synology. I doubt they care as as Cwichura has said it is a nas not an audio player. Look at an Allo Digione if your player accepts spdif input.

The problem is not so much the NAS, it is the Cambridge Audio device. The CXN streamer has been well discussed on these pages for being unable to work well with Linux via its USB. The issues are no sound or or limitations to USB audio class 1, which is only up to 96/24. Search these pages for previous discussion.

Thanks all for the responses, indeed a proper streamer will always be better than the USB on the NAS - no doubt.

As an update I realised that by default the USB input on the CXA80 is set to class 1. I had to configure it to class to (turn off the ampli, press the “A B” button until it blinks, press the A4 button to set it to blue which sets the USB input to Class 2, press “A B” button again which will switch it off and save the settings). I am now smoothly playing a 24/192 file from the synology directly to my CXA80 via USB. It’s actually very decent, bass is a bit fuller than via the hifiberry, but there’s a lot less “body” in the music (ie. a bit like a grilled chicken vs deep fried chicken)!