(Synology) Since last ROON update to version 2.0 (build 1133) I can’t stream in AAC

Roon Core Machine

Synology NAS DS918+ , ROON RAAT located on SSD connected by usb

Networking Gear & Setup Details

Synology > FritzBox 7530 > SOtM switch > dCS Rossini streamer/dac

Connected Audio Devices

Number of Tracks in Library

Description of Issue

After the last ROON update to version 2.0 build 1133 I can’t stream Roon radio in AAC anymore. Before ‘build 1133’ there was no problem.

Thx, I’am gonna try. I let you know…

Hi Hickman,
I’am sorry but this doesn’t help. I did exactly what you wrote but still no AAC playing possible.
Do you have any other idea……?

Hi @Fred_van_der_Pauw ,

sorry for the trouble. I am still pretty sure, it is related to the ffmpeg file.

Could you try the following: Login to your diskstation as admin user.
Open FileStation and navigate to your RoonOnNAS/bin directory.
Right-click on the ffmpeg file and select “Properties”.
Click on the “Permission” tab and select “Create” there.
Select “RoonServer” for the “User or group” field, set “Type” to “Allow” and click all checkboxes in the Permission-Section. Then click done (and “Save” in the previous window").

Now restart RoonServer again in the Package Center. If it still does not work, please check if you have downloaded the right version of ffmpeg (the one for amd64 platform is needed) and if you have extracted them correctly.
You can also take a look at the RoonOnNAS.log.txt file in the RoonOnNAS directory. It should give you info on the used ffmpeg version.
It should contain a line like this, if everything is working as it should:

18.11.22-04:27:58 --- ffmpeg: /var/packages/RoonServer/shares/RoonServer/RoonOnNAS/bin/ffmpeg

If the “RoonOnNAS.log.txt” file does not exist, make sure you have the latest installer of RoonServer installed. The latest one can be downloaded on the RoonOnNAS website.

2 Likes

Hi Cristopher, thanks for your advice but…
this still doesn’t work. To be sure I did everything well I add a few screen pictures I made…


I’am afraid I will have to reinstall Roon but I’am not sure it will not happen again…

The aac stream doesn’t stream here either. The mp3 320 stream does. Maybe the aac stream link is broken.
Happens often by radiostreams.

The AAC stream for this radio station is working here normal on a DS920+ with the RoonOnNAS package.

DSM 7.1.1-Update 1, Roon 2.0 (build 1155) earlyaccess, RoonOnNAS package version 20211105, ffmpeg in subdirectory bin from RoonOnNAS

I only listen aperently to stations with standard mp3 streams. Found another aac stream with doesn’t play either.

@fietser, dit jou install ffmpeg in the RoonOnNAS\bin directory.

Don’t know. Never missed it. Just roononanas file from criecke couple of times for updating.

Before the last update I didn’t have any problem.
A friend of mine who plays with Roon on QNAP NAS also has the same problem. We can’t play any AAC files by radio streaming. So I expect the problem is a software issue ….

@fietser, @Fred_van_der_Pauw, did you both really copied the ffmpeg file in the subdirectory “bin” within the “RoonOnNAS” directory? You have to do this manually; the RoonOnNAS package does not do this for you.

You can find the ffmpeg file on https://johnvansickle.com. Choose the arm64 version and unpack the file ffmpeg. You only need this specific file. After copying the file ffmpeg to the bin directory Roon will play AAC files. It is possible that you have to restart the Roon package first.

Thank you for your reply Alfred.
I already did this but I will give it another try tomorrow…

Problem solved!! I did not put the ffmpeg files in the ‘bin’ of RoonServer map (…).
Strange that this problem happened after Roon’s software update. I hope this does not repeat.
Thanks to anybody for your advices.
I am a happy listener again.

The ffmpeg file should not get touched by the Roon Server itself or any update. However If you select a new database location during install, the ffmpeg file might be missing at that location (because a new RoonOnNAS folder with its own bin directory gets created.)
Glad you could solve it!

Hi
I am facing the same issue… MP3 were working but AAC files not.
Did all the adjustment as per above instructions but now either MP3 nor AAC file are working. Actually nothing from my own library is working now. Not sure what I’m doing wrong. Also did a restart of Roon Server and also of the NAS but it’s not working.

Any Idea what the issue could be?

Edit: my local library is working through ARC though! That’s confusing to me.

@crieke würde deine Unterstützung hier sehr schätzen… Stehe voll auf dem Schlauch.

Thanks for your help.

Hi

Sorry for the hustle… all is working fine now!
I just downloaded the wrong ffmpeg file.

amr is not the same as amd! It took me a while to spot it! :face_with_peeking_eye:

A post was merged into an existing topic: I have the same problem