Synology SPK-Package: Development

Short update:
I have builtin a check if AudioStation is installed on the system. If so a missing library is linked to the Roon Appliance folder from the AudioStation package. This should fix the ALSA compatibility check and you are able to play music directly from your NAS (if a USB Audio device is connected). I tried it yesterday and it works.
So if you want to use this feature you need AudioStation installed. I am still unsure if I could put that library into my package (need to get some info about license and if the library is the same file on all x64 models).

I am unsure about @krjtx issue. It seems the Mono framework is not acting correctly. If anyone else is experiencing this please let me know to find out what might be the cause of this.

You can specify any folder for import now as long as it contains a “RoonServer” and “RAATServer” folder.

I have tried both ways to perform the install.

@remi_alberge - Yes, even though the RoonServer and database are on a SSD volume, using the search function in Roon has a delay of a few seconds ( 4-5) before returning results.

@Lundmark - I recommend making a new volume on the SSD and install RoonServer on it, that will yield better performance for Roon than using the cache feature

I see. But I just read you comment about searches that still take a long time. Maybe SSD is unnecessary then?

@Lundmark - Well I have not tried it without using the SSD volume. When I had RoonServer running on either MacOS or Windows I always had it on a SSD drive.

I am going from guidance in this post.

I can’t get it to work with iTunes. It intermittently says it can’t find the XML, and no albums show up. Any ideas?

I just tested it on a native debian install. Same issue there. So I guess it has nothing to do with the synology/spk file…

Oh interesting. So it seems to be a Linux issue then?

I’m runinng RoonServer on Atom D330 with 3GB RAM and Intel 320 Series SSD on Ubuntu14.04 inside docker container and Roon is very usable except the search function which took 5-10 seconds to start showing results.

RoonAppliance is occupying about 620MB or RAM and there is still about 600MB RAM free and 500MB of cache in RAM. Tried to disable swap completely but no change (swap was anyways barely used when enabled).

Library is located on NFS NAS connected via GLAN and storing about 75k mostly flac tracks / 7000 albums.

Roon is connected also to my Tidal HIFI account

Quick question: If I were to install this spk on my Synology and import a Roon database that I copied over to a share on that Synology, can I remove that folder after the installation? Or does this folder become the actual location of the db?

It will copy the database to your installation volume.
I’d still recommend to keep the original at the moment as the spk is still in a testing phase… :slight_smile:

I have installed the pck on my Synology 713+ containing 2x500GB SSD and can’t notice any lag of significance, but I have a small music library onboard.


Thank you very much for sharing this work. I’m running on a DS415+. So far it all seems to be working fine. It’s now playing through a Raspberry Pi Roon Bridge coming out of the analog output using a headphone it is ill equipped to drive, just to verify it’s there. I’ll report back after I’ve done some serious testing through my main system.

Maybe Roon can supply a Synology package in their next releases soon.
Would be an amazing improvement if they are able to do so.


I need some help. Im probably being dim and not done something, but I cant get the spk to work.

It installs on my Synology DS412+ fine and says its running,. Am I understanding correctly that this server is then configured from any remote roon installl? If so the problem is I dont see the NAS in the server list. My existing core is (on a laptop) is visible.

You could try by manually adding the ip of your nas in the server connection screen (i believe there is a drilldown allowing you to do it)

Thanks but I tried that to no avail

Could you check in the Synology Package Center if the Status of Roon is “running”?
krjtx had issue as well with errors of the mono framework. As the DS412+ uses the same cpu, this could indicate a general incompatibility to the cpu (Intel Atom D2700).

As 2 users with an Intel Atom CPU have already reported RoonServer is not starting. Was anyone here successful in using the spk with one of the following models:

CPU: D410

  • DS710+

CPU: D510

  • DS411+
  • DS1010+
  • RS810(RP)+

CPU: D525

  • DS411+II (working)
  • DS1511+ (working)
  • RS2211+
  • DS2411+

CPU: D425

  • DS712+

CPU: D2700

  • DS713+ (working)
  • DS412+ (working)
  • DS1512+
  • DS1812+
  • DS1513+
  • DS1813+ (working)
  • DS2413+ (working)
  • RS814(RP)+
  • RS2414(RP)+

CPU: C2538

  • DS415+ (working)
  • DS1515+ (working)
  • DS1815+ (working)
  • DS2415+
  • RS815(RP)+
  • RS2416(RP)+

If this is a general incompatibility with certain cpu-types I will modify the spk to not install on those machines.