System Output Doesn't Work

I installed Roon just a couple days ago. Put it on Win10 machine… server, bridge and Roon software working as remote. At first, I had ‘system output’ (use device volume) and also had my video card showing up which I enabled under exclusive mode (use dsp volume, as I don’t normally adjust volume with my receiver). Both were working, and ‘system output’ would share the audio with other devices on my machine (eg, web browser sounds would also be audible). The only difference between the ‘system output’ zone and video card zone, was whether it would be in exclusive mode.

Then, the video card output (exclusive mode) stopped working about an hour into Roon. I updated my video card drivers (1660 Super). And I fully removed and re-installed Roon. One of those fixed it, I think it was the video card drivers.

Now, the video card output works but ‘system output’ does not. It shows up and lets me pick it, but then flies thru the queue without playing anything. I fully removed and reinstalled Roon, clean installed video card drivers again (restarting between each step just to be safe)… Still the same thing, ‘system output’ jumps past a whole queue without playing anything. Also, since exclusive mode seemed to be the only difference between them, I tried my video card zone without ‘exclusive mode’ checked; it flies thru the queue without playing anything also. I tried flipping volume control between device and DSP and it didn’t help - not that it should’ve but I’ll flip any switch! As soon as I switch back to exclusive/wasapi mode then it plays. I want to have both those zones like I did at the beginning - so that if I want the other sounds from my computer to come thru, I can have them.

Can anybody help me? I’m sure there is probably more info I should provide, but not sure what it is. Below are a couple of screenshots.


The one on the right (only) works:

If I turn off exclusive mode, it doesn’t work anymore:

Tell use about your windows audio set-up… what kind of sound card, what’s your default output, etc.

I have win10, the sound comes thru the video card - Gforce 1660 Super. All the other sound outputs are disabled (and have been for a long time). The drivers for it come from “Nvidia Gforce Experience” settings program that checks/updates drivers. I have all the features in that program turned off (never used them). The video card is hooked up to my receiver/TV by hdmi - I also use this computer for movies with Master Audio. A couple screenshots from control panel are below.


device list:

default device properties:

Trying to understand…

So sometimes you use the video card as exclusive and sometimes you use it as system output? That just sounds like a set-up which will cause problems.

Basically, if you select the shared output but something else already has exclusive access to the output then the Roon behavior you describe can happen. It sounds like something on your system, maybe Roon itself, already has that device in exclusive mode. What happens if you disable MSI Exclusive, reboot everything, then enable System Output? Does System Output work? If not I assume something, besides Roon, is preventing Roon from using that device through the shared OS mixer.

You can also, in the configuration I suggest above, try unchecking “Allow applications to take exclusive control” which will prevent another app from capturing the device.

1 Like

I use exclusive output mode for watching movies, and for listening to Roon when I want it to sound better - I believe (and my wife who doesn’t believe in such also does) that it sounds better that way.

Nonetheless… good idea for switches to start flipping around.

I unchecked “allow applications to take exclusive control of this device” and still, System Output behaves the same way and won’t work.

Spotify, which I don’t ever use in Exclusive Mode, can play whenever it likes. Web browsers can make sounds whenever they want. If I’m watching a movie, or if Roon is running in exclusive mode, other apps just can’t make sounds. But the moment I stop watching the movie or pause Roon, they can. I’ve never had any issue with anything but Roon - which was working as expected (both modes), then only in non-exclusive mode, then as expected again, then only in exclusive mode, and then after changing the above settings, wouldn’t play in either mode anymore.

I got it to work again - but only in exclusive mode - by putting everything back how it was and then turning on ‘work around devices that misreport capabilities’ which let exclusive mode play but full of constant popping and crackling. Then I turned off that slider (work around devices) and immediately it is back to how it was before I started with the settings you suggested to try (exclusive works, non-exclusive doesn’t… but any app other than Roon can make sounds without using exclusive mode).

Not sure if it’s related at all… but exclusive mode has always made a small amount of popping/crackling toward the end of any track that goes quiet - whereas non-exclusive mode, when it’s working, doesn’t do that but doesn’t sound as good otherwise. It seems odd as there is no evident hdmi handshake or anything going on. This bit of popping/crackling is annoying but not extreme, figured I could live with that and maybe it’s related to the computer or receiver (although it never happens with movies).



I figured out a work-around for this. Maybe somebody else who likes some Roon features but can’t get it to work outside of exclusive mode, will find this helpful…

System Output initially worked, but now doesn’t work no matter what I try… So I downloaded VB-Audio Cable and routing Roon to that via Wasapi, then VB-Audio Cable output to my video card. (I have two different outputs for my computer listed on Roon now - one goes straight to video card by Wasapi in exclusive mode, the other goes to VB-Audio Cable by Wasapi / exclusive, which then routes to video card in non-exclusive mode.)