The Beta Channel: what's cooking? Now at 4.019 (2021/11/13)

On request, I’ll write down some short release notes in this topic when I push something to beta.

Some simple rulez: this is not a “I want feature X” kinda post. Or a “when do we get” kinda post. I simply will ignore those.

And an observation in general: I notice people running beta without actually understanding what it means: beta. It can break. It will brake. And it can take a while before I repair the broken stuff. Or people switch to it because something is not working on stable. Please don’t do that.

Those that feel ‘brave’ enough to test it are welcome and feedback is highly appreciated!

Kind regards,


2.536 (2020/06/21)

  • update Alarm Clock Extension to 0.8.2
  • lay the groundworks for an init screen (the web page you seen when your unit is booting up) that also shows if an update is being applied, as this can take a little while
  • make sure the init webpage is being refreshed

2.538 (2020/06/22)

  • more work on the init webpage screen
  • updated the alarm extension
  • reworked the device info stuff. This is now being requested every 5 minutes

So, wrt to the Alarm Clock I need someone to test it. I’m curious if the issue wrt wrong time/date has been fixed (I’m pretty convinced it is).

Ill try and do a test today

1 Like

That was the only unit that has the alarm clock function turned on.

you mean the ‘hanging’ unit?

yes only run alarm on that unit

Ok clear. Then I can explain it.

As said there was an issue with the update of the Alarm Clock itself. As this was the first time since it is included in RoPieee I updated it this manifested itself. This has now been resolved.

Would love to hear if the other issue with the Alarm Clock is resolved as well.

1 Like

Can someone already say something about the alarm clock issue wrt rebooting as mentioned earlier?

I missed what the issue was and got tied up with life drama last night as the mrs wanted an early night so no music in the room.

Ill try again in a bit…rebooting was the issue?

OK a pause with fade on another zone other than that of the RPi with Alarm running ran fine…no reboot.

Here is a feedback 598876927034b91a just after it did the action if you perhaps needed to check what happened.

I have not experienced any issues with the alarm clock since updating to beta, including some reboots.

2.539 (2020/06/27)

  • hardened the remote extension a bit
  • switched to ‘pills’ instead of ‘tabs’ on the webpage and introduced tabs on the XL page

Looks good Harry, a little bit of polish is always welcome.

1 Like

2.540 (2020/06/28)

  • updated webpage wrt Shairport-Sync volume control (XL) to make it clear that it is software controlled for now. This is in further preparation for hardware mixer support.

Harry, I upgraded my beta unit to XL to view the tabs, and the upgrade hung after loading the x.509 certs (took a photo, if you want it? Didn’t run the command line send feedback under /opt) I logged in, verified that dmesg didn’t show anything more afterwards, and tried a simple reboot, which worked perfectly.

I do like the tab layout, which is cool.

Yeah please send me the photo.

Is this perhaps also the problem with upnpcli/mpd? The DAC I am using does not do USB volume control. I have RoPieeeXL set to “none” for the various protocols. Airplay I get full volume, same as with Roon Bridge. But for DLNA/UPnP play from the native Qobuz application, the volume is like 25% of normal. (This is on the most recent stable channel update, FWIW. I left the feedback ID for a session attempting to play to it in the release announcement thread.) I’m wondering if MPD is still applying some kind of software volume control when it shouldn’t be.

(Also, do you want people to play direct to the mpd daemon running on RoPieeeXL as a feature? If not, maybe consider adding the option switch to prevent it advertising itself via mDNS/Avahi.)

It is. I already mentioned this earlier in a separate post. All volume control is software.