The hard disks on my QNAP NAS never go to sleep (enter standby mode)

Good afternoon,
I have an Intel NUC running Roon / Rock OS. I also have a QNAP NAS with all of my music stored on it. I noticed that the hard drives in my NAS never go into standby mode (go to sleep). I initially thought this was a Roon software issue but after further investigation it looks like it might not be. I disconnected my QNAP NAS from my home network and noticed that the hard drives were STILL not going into standby mode. My Roon database / library is stored on an internal SSD inside the Intel NUC. After some help with QNAP suppoort help desk it looks like an application called Samba is the application that is preventing the hard drives in my NAS from going to sleep. I’m not sure I even know what Samaba is. Does Roon need / require Samba to function? If I disabled Samba on my NAS would Roon still work? Looks like Samba is some software package that implements the SMB protocol (Server Message block whatever the heck that is!!!)

Do you have the QNAP HD Station enabled? Last time I checked (long time ago), this prevented hard disks from sleeping. Maybe similar for other media center software on the QNAP.

EDIT: I see now that you have zoned in on Samba. Samba is what provides the Windows SMB file sharing server on QNAP and every other Linux-based server. So if you have network shares on the QNAP that you access from other computers via SMB, you need it.

Searching for this issue on Google, many people have it with QNAP. Not sure if Samba always behaves like this, but it’s server software, will write logs, etc., so I’m not entirely surprised

I logged into my QNAP NAS and took a look in the “App Center”. I don’t see anything in there that looks like QNAP HD Station. The ONLY thing that is stored on my NAS is my downloaded music files. The only thing that uses my NAS is ROON running Rock on my Intel NUC. Occasionally / Rarely I map a network drive on my Windows laptop PC and copy a couple of newly downloaded music files.

Your issue is probably caused by Samba

The question is not so much how often you access it from another PC, but whether you do at all. If you do and it works, your QNAP probably has Samba running. You could shut down Samba on the QNAP when you don’t need it, but then you always have to turn it on when you do. It’s called “Enable file service for Microsoft networking.” in the QNAP Control Center

Be aware that if noise doesn’t affect you, there is no problem with spinning disks staying on. That’s what they are there for, at least if you equipped your NAS with server-type HDDs. Turning them on and off frequently breaks them faster. They will have a higher power usage when spinning, but if you want to calculate that accurately, you also have to factor-in the cost of replacing the disks possibly being higher when they are on/off all the time.

(There are probably ways to change the Samba configuration so that it does fewer disk accesses, logs less or into another place, etc, but if you had to ask what Samba is, I don’t think you want to dive into this :slight_smile: )