The starts of tracks cut off when HQPlayer set to output DSD

Hi all,
I’m trying to fix a problem that’s been bugging me for a while: whenever I use HQPlayer (desktop, on Linux) to output DSD (actually DoP) the start of the track is cut off. This doesn’t happen when I choose to output PCM or output PCM or DSD (again DoP) but using Roon’s upsampling capabilities, which is leading me to suspect that HQPlayer is the key to sorting this out but I could really do with some help tracking the problem through. My component chain is as follows:

Synology NAS
Intel NUC running Roon Rock
Dedicated PC running audiolinux and HQPlayer desktop
Twisted pair dual mono 9028 DAC

This is not something that happens occasionally, or with tracks that are being upsampled from a certain file format or frequency, it’s every track, all the time – except, with one caveat: If I play native DSD64 tracks then less appears to be cut off. However, this might purely be my imagination as I have no scientific way of testing!

I read some mention of a Roon resynch delay feature but that setting doesn’t appear for HQPlayer inside Roon (or at least I can’t find it).
In the SMS-200 HQPlayer NAA settings menu there is a period time box. I have hunted for an explanation as to what this is but cannot find anyhow. However, I did find another user reporting a setting of 32k or so (Currently it’s at 4096). I tried setting it to the much higher number but it didn’t affect anything.

I’m clutching at straws really so any pointers would be much appreciated.


HQP front end settings:

HQP settings:

DSDIFF/DSF Settings:

@jussi_laako will most likely come along to support you but in the meantime I suggest using default for buffer and DAC bits and having multicore greyed.


1 Like

Thanks for that John, I updated the settings. Unfortunately, it hasn’t cured my particular problem. Thanks for flagging to Jussi, I’ll see what he says.

1 Like

Hi crom,

Is the SMS-200 running the latest version of their software ?

Thanks for dropping in. It is. I’ve also looked at tha various network settings on the switch but suspect that the network is sound as it works fine using the sms200 in roon-mode.

1 Like

Good starting point would be to reduce number of variables, by removing both Roon and the sMS-200 from the picture. Just standalone HQPlayer directly to the DAC.

I wonder what is the USB interface in question, it should support native DSD instead of DoP?

At start, HQPlayer plays a DSD silence pattern that keeps Sabre (and most other DAC chips) muted. Then various DACs have different delay for releasing the mute when the silence pattern ends. But this should be only about 50 milliseconds or so.

Thanks @jussi_laako for dropping in to help - much appreciated.

I didn’t realise that it was possible to play hq player straight into the DAC. USB out from the PC with HQPlayer on it and then into the DAC? I will investigate and report back.

The USB interface does not support native DSD via linux, only via DoP. Will this be a problem? The full spec is available here: