Third speaker out of sync

Hello!

In my three speaker setup, one speaker always seems to be out of sync with the other two. I have got Mini and a Flex in my living room and another Flex in my kitchen. It’s that one that plays music at another time. The problem does not occur when I play music from BlueOS. The speakers have the latest firmware and are not grouped in BlueOS. The DSP engines have been disabled for all speakers. The only thing I did from Roon was group the speakers (after having rebooted the Flexes once and the Mini twice before Roon could discover all of them).

Is there a way to solve this problem?

Thanks in advance,
Frans

Frans, I am having the exact same problem with synchronisation. I recently discussed it in the forum and asked for support. From what I understand, while roon keeps everything up to date (including improvements to RAAT), Bluesound has not necessarily included these updates. This may (or not) explain what we are experiencing.

In any case, I am experiencing the same issue with Bluesound. In contrast, Roon Bridge zones are perfect and always in sync.

Best
Yiannis

Same problem here,1 bluesound Node 2 and 1 Sotm 200 and 1 pulse 2.
I can not put all together anymore.
When I stop the Node 2 its ok.
Only hope one update from Bluesound or buy another Sotm 200 (verry good sound)

Best

Patrick

Yesterday, Bluesound have made new firmware available (version 2.14.5), but it does not seem to have resolved this problem. I wonder if @support knows something about this issue.

Regards,
Frans

Just to add to this: I have been in the Bluesound support forum asking about the issue. It appears that Bluesound was still using RAAT SDK version 1.1.15, at least up to firmware 2.14.0

I am not sure if this was responsible for the sync issues but it might. Either way, it is worth checking if the latest firmware update by Bluesound has included the up to date RAAT.

BluOS 2.14.5 still sports the old RoonReady SDK (1.1.15) – no changes on that front.

@Frans_Knibbe / @Yiannis_Kouropalatis / @Patrickvm ---- Thank you all for the feedback and sharing your observations with us. Very appreciated!

Moving forward, if one device in the group seems to be “causing the problem” I would recommend setting the “clock master priority” to the highest setting for that device and a lower priority on the other two devices. This setting can be found in the “zone grouping” tab under “device setup”.

Let me know how it goes!
-Eric

Thank you for the tip Eric, tried it already and unfortunately it did not improve the situation.

I was running 3 zones: Bluesound Pulse 2, Bluesound Flex and a Naim Nova. I tried setting one of the Bluesound zones as the highest priority but this did not stop the sync issues. The Bluesound zones seemed to stay in sync with eachother for longer but eventually they too became out of sync. I even tried connecting them to the router with ethernet cables. The Nova was wireless (the only zone to be so) and it was still going out of sync after about 20 mins.

Finally tried with just two zones: A pulse 2 and a PC running roon bridge (both wireless). Out of sync sound withing 15-20 mins unfortunately.

No problem at all when removing the bluesound speakers. Running the Naim Nova and the PC (roon bridge) results in perfect sync.

Hope this helps

This could be a clue. Over time, the RAAT and the RoonReady SDK have seen various optimisations for playing to grouped zones, specifically on WiFi.

Bluesound have been slow in rolling out those changes: BluOS devices are still stuck on version 1.1.15. The big hold-up is handling MQA when sent from Roon, which appears to require some structural changes at BluOS firmware level.

I believe the current SDK version is 1.1.22 – what version does your Nova show?

48

Hello Eric,

I tested as follows: ungrouped in both Roon and BlueOS, rebooted the Mini (otherwise it is not detected by Roon), set the clock master priority to highest for the speaker that was out of sync (my Flex kitchen speaker) and lowest for the others. Then I grouped the three speakers in Roon. A first test has the three speakers playing in sync now. Before I release the pigeons I would like to test if they stay in sync, as Yiannis wrote the problem could reappear after some time. But the recommended setting did seem to have an effect.

Regards,
Frans

2 Likes

I would love to check but unfortunately I no longer have the Nova. It developed a fault and had to be returned.

I can however confirm that I am running Roon on two zones and in perfect sync:
i) MacBook pro (Core) and ii) PC running windows 10 (roon bridge + Remote).

The Bluesound Pulse 2 would not stay in sync even when grouping with a single other zone (PC). For that test (2 zones only) I set the Bluesound pulse 2 as the highest priority.

I am inclined to believe that the issue is due to Bluesound’s old RAAT version.

Cheers

Hi, I am afraid I have to report that the problem resurfaced after a few tracks were played. So the clock master priority fix was not a permanent solution in my case.

Sorry to hear this Frans, i have also not been able to find a solution unfortunately.

Based on my tests, the sync problems always appear when a group includes a Bluesound zone. I think you actually have 3 Bluesound zones? I only tried grouping two Bluesound zones and then something even simpler: One Pulse Flex + PC (roon bridge). Just two zones. Music starts in perfect sync and gradually drifts and becomes out of sync (20 mins or so).

It appears however that two zones with the up to date roon bridge will stay in perfect sync (PC + Macbook pro).

I have discussed the issue at the Bluesound forum and the feedback is that it will take time (no indication how long) for them to integrate the updated RAAT. Even if and when they update… we have no certainty that this is the cause of the problem. It is a working hypothesis for sure.

While I appreciate the Bluesound SQ, reliable multiroom audio (in sync) is quite important for me so I am considering options on how to proceed next:

i) Replace Bluesound zones with Roon Bridge zones (mini PCs) + speakers
ii) Go back to Sonos for multiroom audio to regain some reliability at the expense of SQ of course
iii) Forego multiroom audio in sync
iv) Wait to see if and when Bluesound updates RAAT on their side.

Anyway, hope it all works out better for you
Y

Hello Yiannis,

My latest test was done with one Bluesound group (a stereo pair) and one solitary speaker. I grouped these two into one zone in Roon. It is quite possible the same thing you describe happened.

I was in an (extended) trail period for Roon and I decided not to start a full membership because this is a blocking issue for me. I am sorry I can’t continue with Roon for the moment, because its functionality is vastly superior to that of the Bluesound desktop controller. And if the problem is truly caused on the Bluesound side I am doubly sorry. But for me it’s back to using the Bluesound software only for now, which is feasible in my case because I all my speakers are from Bluesound.

Greetings,
Frans

@Frans_Knibbe / @Yiannis_Kouropalatis / @Patrickvm ---- Thank you all for the continued feedback and more importantly, thank you for your patience.

To bring everyone up to speed, I had a chance to touch base with the tech team yesterday regarding this behavior you are experiencing with your BS devices. As per the conversation, I was informed by the team that Bluesound is currently working on getting the new RAAT version rolled out for their devices, but you’ll have to check with Bluesound as to when that might be released.

-Eric

1 Like

This is not great news to a prospective buyer like me. Lots of other people happy with the Pulse Flex here so it’s strange.

Hi @AndyP

I was wondering about this as well but I think that some users do not group speakers for multi-room so they do not encounter the issue. What’s more is that the Bluesound speakers stay in sync if controlled via the Bluesound app (assuming a very stable and robust home WiFi).

Depending on the use case, it is possible some people may not come across the sync problem we encountered. Of course this conclusion does not help me (or the others with the same issue) but to my mind at least, it is a Bluesound issue to resolve. Having said that, I can certainly see how Roon’s customer value increases if/when it works reliably in conjunction with Bluesound speakers as end points.

Had I known of this in advance, I would have still purchased Roon but I would have opted for different hardware end points. Probably a combination of roon bridge end points.

I am also definitely keeping my sonos speakers which work well and in sync when controlled via Roon. There are some glitches there as well but they are easily managed.

1 Like

Hi Yannis
Thanks for this. The thing is I do want to have a multi room zone in Roon. So I might encounter the issue. I guess I wont know until I try is what you are saying.

Unfortunately I would echo having difficulties with the Flex (in contrast to my Node 2, which is rock solid). For a long time it didn’t like my WiFi and used to vanish at random (unlike any other device, e.g. an RPi based steamer). Powerline adapters addressed that and it was stable with the Bluesound app. Now, new WiFi (Ubiquiti AC Pro) also provides stability in Bluesound. However, things with Roon have never been quite right - sometimes it audibly drops out, sometimes it just logs dropouts. Upsampling to 88KHz or higher can sometimes lead to a hard crash (see also Seeking Help from Bluesound Node2 Users ). These issues, alongside the slow response by BS to Roon integration bugs, lack of MQA through Roon and now the timing issues in grouped zones have put me off purchasing others. It’s a great shame really because it sounds great and, as I say, my Node 2 is rock solid, which does suggest that the issues may not lie so much with the version of RAAT as some specific problem with the Flex. As things stand, I do not see the Flex as Roon Ready, though I realise many people seem to be using it successfully.

2 Likes

This is useful information. Thanks.