[Ticket in] B224 missing covers a second after going offline [seems fixed ARC B1260]

Really? Boarded a flight, turned on airplane mode on the iPhone and offline mode on ARC, and it looks like this:

Just tried - same here…

Hi @Suedkiez ! Thank you for flagging this.
We would highly appreciate any details that would help us to reproduce the issue. Do you remember, by chance, how this media was downloaded? Was it downloaded after the latest build update, or is it an “old” one? Is there any specific data about albums you can share with us?
Thanks!
Regards,
Oleh

The albums in the above screenshot are very likely manual downloads from pre-SDL (they don’t show format info, as discussed in the B223 feedback thread after SDL became available), but I just tried again.

I arrived at my destination hours ago and have wifi and 5G - and covers are fine as soon as I am on wifi or 5G.

For testing I once again enabled airplane mode and ARC offline mode. The albums from the above screenshot now had covers, but most didn’t and this includes recent SDL downloads:

Hi @Michael_Curtis . Can you, please, add any details that can help us to reproduce the issue? Is it still reproducible on your end?
Thanks!

I still can and all it takes is enabling ARC‘s offline switch. I just tried again, just like my second post further up, affecting new SDL downloads just like old ones. Yesterday on the plane I noticed that my profile icon also switched to a generic one, but this corrected itself when I went back online and just now it didn’t happen.

And some covers are displayed, but the vast majority isn’t

1 Like

Thank you, @Suedkiez ! It’s not reproducible for us, that’s why we’re trying to get some additional data to get into this state. How big is your downloads library? Do you see album covers when you open the downloaded album details page (in offline mode)? Are album covers present when you play them in the offline mode?

I’m just downloading some albums to try again (we have a weekend apartment so I’m regularly swapping cores and therefore often have to reset ARC). I’ll report back in a while.

Michael

1 Like

30 GB assigned to SDL. I had quite a lot older downloads pre-SDL, several 10 GB as well, I think, which I had just downloaded manually a few days before SDL was released. After SDL release I deleted some of those, and I switched some SDL downloads to permanent. Overall:

Nope, not for affected albums:

My ARC home page is fine now, though, and the covers that appear there are also present in the downloads list:

1 Like

Evidently, the covers that are cached during the initial download didn’t stick, but I am not sure if covers that get re-cached later during normal use disappear again.

So now I went online and scrolled through the whole download list, which made all covers appear. Then went offline and they were still there, for now. I’ll report if this stays or if they disappear again

2 Likes

Thank you so much for your efforts!

1 Like

Well, I have smart downloads set at the default 5GB amount, and I’m not able to repeat the issue here at the moment, with any combination of Airplane mode and/or offline within ARC.
I’m using the most recent early access versions of server and ARC. I’ll keep playing and if I’m able to repeat the problem I’ll report back in this thread.

Michael

1 Like

To add to this I am seeing the same thing when I tested going in to offline mode just now

The second screenshot is all smart Downloads of newly purchased albums. One or two of which I have converted to downloads.

1 Like

Thank you @Michael_Curtis !
Kind regards.
Oleh

Thanks @Michael_Harris ! Can you, please, share with me your downloads library size?

Of course, it’s not small as I was testing out smart downloads :grin:
All working fine in online mode and I have migrated a fair number of smart Downloads to full downloads as well

1 Like

@oleh partially gone again, this is after updating to B225, then going offline:

There are slightly more albums with images than last time, but the vast majority is still grey.

After making the screenshot, I went online again, immediately went to the downloads browser, and started scrolling quickly through the list. Maybe interestingly, the covers seemed to be immediately available, without them getting visibly updated while scrolling.

Then I went offline again and, like last time, the covers remained visible.

Will monitor how it looks tomorrow

1 Like

I’m not sure if the reason is the same but I experience slightly similar behavior with Android Auto.

No covers are visible in Android Auto when ARC is offline.
The only way to have cover displayed there is to start playing album while still being online.

Having said that I must admit that using ARC outside of car I can see covers (although in low resolution).

Hi, @Michael_Harris ! If this is possible can you, please, confirm or recall the following:

  • it was an Android device?
  • were the albums downloaded in the background? If so, how often your phone was used (ARC called to the foreground) during the downloading? Were there some obvious interruptions?
  • after enabling smart downloads or queueing some items, how frequently did you foreground-backgrounding the app?
  • did you download it on wifi or a mobile connection? Have you transitioned from wifi to mobile during the download? Was “allow mobile downloads” enabled in the settings?
    Your answers can shed some light on the issue.
    I would also ask you to try to reproduce the issue again, on the recently released build, and let us know the results.
    Kind regards,
    Oleh

Hi Oleh Answers inline below

it was an Android device?
Yes a Google Pixel 7 Pro fully updated

were the albums downloaded in the background? If so, how often your phone was used (ARC called to the foreground) during the downloading? Were there some obvious interruptions?

Some were downloaded in background, but all battery optimisations for ARC are turned off.

after enabling smart downloads or queueing some items, how frequently did you foreground-backgrounding the app?

Not that often, I go in to see what it is doing and sometimes moving smart downloads to permanent Downloads.

did you download it on wifi or a mobile connection? Have you transitioned from wifi to mobile during the download? Was “allow mobile downloads” enabled in the settings?

All downloads are on WiFi at home

Your answers can shed some light on the issue.

Doing some testing now and it looks like a batch failed to go get downloads at some point
This is the latest

In date order there are dozens of smart downloads without covers when in offline mode

Hopefully this helps a little, but happy to do more testing.

2 Likes