Tidal albums not loading in library

Does someone else experience the same problem as I do?

Launching roon, it only seems to load my locally stored albums + qobuz library:


But I would have 2K+ albums on Tidal in my library. However, when searching these albums, they still appear:

So, Tidal service is working / connection is established, I could add albums and I can also search albums and find them and play them… but for a reason, I can not browse them via Focus.

I would…

a. Check to make sure you don’t have an existing Focus which excludes Tidal
b. Sign out of Tidal. Reboot the RoonServer software. Sign back into Tidal.

Thanks, Daniel … I did all that! It worked for a bit, but now I seem to have the same problem.

Nobody else?

Well, investigating the statement “It worked for a bit…” Was there any external change that might have happened. It seems very odd for it to suddenly stop when it was working.

Can you post current screen pics of the album page and the album page with the focus active.

Also, I would also suggest as a test installing Roon on a different PC, do not restore a database, and log into Tidal. Does this fresh install add all the Tidal content?

I did restart Roon Server (running on a Intel NUC), and I noticed, that it first loaded the local library, then qobuz, and then Tidal …

However this evening it doesn’t work anymore … I also get this message:

I haven’t added any new albums.

As an example, I opened the Genre view:

Notice, all Tidal albums and in my library

If I click on “more”, I’ll get this result: