TIDAL content is not loading in Roon

I am sorry to disappoint, but even with the new build 555 the problem persists here, just like “What’s New”, “TIDAL Rising” ,"Playlists and “Genres”, which all fail to show content.

Hi @Gustaaf_van_Veelen,

It sounds like something else is happening for you than what was affecting everyone else.

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Is there any change if you reboot the Core?

Thank you very much for your reply.

My set-up is as follows:

Core Machine (Operating system/System info/Roon build number)

Roon ROCK( Version 1.7 Build 555) running on a NUC8i7 BEH2 with Crucial CT8G4FSS8266 8GB DDR4, 2666MT/s PC4-21300 Single rank SODIMM 260-pin and a Transcend SSD, 3d and Flash-Chip 128GB.

Internal storage on a Crucial MX500 2.5-Inch SSD.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ROON ROCK is hard wired via Ethernet cable to my ISP router (Arcaydian V10A).

ROON Remote on both an i-Pad and an i-Phone.

Network is a roaming network with 2 Apple Extreme’s and an Apple Time Machine, all operating in bridge-mode.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

RME-ADI-2 DAC connected directly to NUC8i7 via USB.

In another topic on this matter I already mentioned this. Sorry for the duplication.

I tried a reboot of the core and have reset the ISP router to factory default, all to no avail. Every time the “error reloading page” message is shown.

Could you please help me with solving this problem.

Thank you very much in advance.


Hi @Gustaaf_van_Veelen,

Is there any change if you try using Google or Cloudflare DNS?

Can you try clearing your TIDAL cache?

  • Stop RoonServer from the Web UI
  • Find and open your Roon database
  • Navigate to RoonServer/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting RoonServer and verify if the issue still occurs

Hi Dylan.

Thank you for your reply. My ISP does not allow a change in DNS I am afraid, so I could not check that.
Clearing the cache did not help and I see the same behaviour again with accompanying “ error loading page” messages.

Hi @Gustaaf_van_Veelen,

Thanks for the update. Moving forward, I’m hoping you can do the following:

  1. Reboot your Core from the Web UI
  2. Connect to Roon from your remote device and try to open the TIDAL page
  3. Make a note of the time the error occurs
  4. As soon as you see the error, use the directions found here and send us over a set of logs using a shared Dropbox link


Hi Dylan,

Rebooting the core somehow improved matters a little bit. I now get TIDAL contents, albeit with the same “error loading page” message. The Log file was created at 10:29 (GMT+2) local time when the problem started.
Link to zip file Gustaaf_van_Veelen

The problem re-occurs after ROON remote is awaken from sleep mode. Especially “Genres” in Tidal is affected the most.

Thanks once again.

Kind regards,

Edit: Link to file corrected.

Hi Dylan,

Just realized the link in my previous post might not work!

Link #2 to zip file

Hope this is a proper one.

Thanks for sending the updated link, @Gustaaf_van_Veelen. I’ve passed this along to the team and will follow up ASAP once I’ve received their feedback.

Hi Dylan,

With the latest update, build 571, all problems are solved and Roon works flawlessly like it did a couple of updates ago.
Thank you very much for looking into this!

2 posts were split to a new topic: Content from TIDAL is not loading

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.