Tidal disappeared and won’t log back in

Hi, running Roon core on a QNAP NAS for some time without issue with tidal account linked. Now it says tidal account not available and every time I try to log in in it successfully logs in externally and presents a link to return to Roon at which point it still shows logged out. The cycle repeats. Tidal works fine natively. I have tried stopping Roon, clearing the cache in Roon folders and restarting Roon on the NAS but no joy. The main reason I use Roon is for MQA’s in tidal so I really hope I can get this sorted, thanks.

Hi Davinder,

Have you tried rebooting the Qnap?

Hi, yes multiple times but still acts the same.

I also tried connecting a Qobuz account, that keeps saying network error after I enter my credentials, the network is fine, everything else works perfectly including roon other that not accepting external services, makes Roon pointless for me…

Maybe try rebooting the router/ modem?

Even though you say everything else network related seems to be fine, Roon can be peculiar at times.

Stranger things and all that as it does seem to be somewhat network related.

I have had similar issues with Roon / Tidal over the past 7-10 days or more, and I seemed to have resolved them today by changing my upstream DNS to Cloudflare and rebooting everything (which I had done before). I have no evidence of any definitive root cause, but my family was frustrated so I tried various things.

Good luck.

Hi all, thanks for posting. Mine is working now. Seems like when the NAS updates firmware it exposed a problem where the DNS in the nas was set to an IP from an old router. I set that to auto and with the DNS fixed it seems to have resolved the problem.


So as is often the case a network issue, not Roon…

Yes that’s right.