Tidal doesn’t work

Roon Core Machine

Nuc i5 10th gen. 16 go RAM and 256 go ssd. Powered with an S-booster. My Roon core is 1.8 build 814 stable.

Networking Gear & Setup Details

English Electric8 switch. Chord Shawline cables, ubiquiti Edge router and a netgear access point. I have configured my router to use cloudflare dns. My internet connection is 500mbit fibre.

Connected Audio Devices

Chord Poly/Mojo and Arcam SA30

Library Size

I don’t know. I have a my music on a separate NAS

Description of Issue

Tidal is not working since one week ago. I get two error messages; “Two many failures….” and This track is currently not available from TIDAL.

Tidal works as normal from my iOS devices.

Qobuz works as normal from Roon.
I live in Sweden by the way.

I have tried to delete the Tidal entry’s in the Nuc database and restart the NUC and login to Tidal again. But it didn’t help.

Hello @Johan_Kjell,

Thanks for getting in touch and letting us know of this. We’re sorry about the trouble :sweat:

I was wondering if, as a first troubleshooting step, you could change your Router’s DNS servers from the ISP provided ones to Cloudflare DNS, Quad9 or Google DNS?

I have had Cloudflare all the time. But the problem is fixed. I read about a person here on the forum who had had the same problem as me. For him, it was solved by logging in and out of Tidal’s iphone app and then logging in to Tidal from roon. I tested doing the same thing and Tidal started working from roon. Strange…


Hey @Johan_Kjell

I’m glad that things are working for you now! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.