TIDAL errors on NAS + ROCK

Hi! I also have the same problem with Tidal. It takes 10-20 seconds to open Tidal page and very often it gives errors saying that there is an error in opening page and if I want to reload. After doing so you can load it. Choosing album and then track takes another 10-20 seconds. I have this on two different QNAP NAS’s and on two freshly combined NUCs with freshly installed Rock. It looks like either Roon communicates with Tidal incorrect or Tidal not letting Roon to work correct with service. Qobuz or local files or files located on other NAS plays fine. Tidal on IPhone or on Mac works good, internet connection 890 Mbs. You have to check how Roon works with Tidal and fix it…

1 Like

Hello @Pavel_Ezubov,

Welcome to the forum! So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Is there any change in behavior if you try to log out and back into TIDAL via Roon Settings -> Services?

One place I have Roon installed on QNAP NAS TVS-471, music stored on Synology NAS, all connected by wire to Cisco commutator at 1Gb and then to internet at 890 Mbs. local players are Linn, HiFiberry, Bluesound Vault 2i, Aplle TVs, DCS Bridge. All connected by wire to the same commutator. Recently I purchased NUC - NUC10I5FNK2, installed there 32gb Ram and Samsung 979EVO 500Gb SSD and installed fresh Roon Rock and again connected to the same commutator by wire. Each system plays fine local files from NAS, plays fine Qobuz but when I choose Tidal it pauses for 10-20 secs, then shows error mesage with proposal to renew it and then finally shows albums and tracks. Looks Roon communicates with Tidal different than with qobuz…
I do other system in my suburb house - Roon installed on QNAP but different model (dont remember exactly), files stored on Synology NAS, all connected by wire to 1Gb Cisco commutator and then through optic cable to ISP. Have the same problems. I have there HiFiBerry, AppleTVs, Ayre QX-5 Twenty, Hegel HD190, Bluesound wireless speaker… Same situation there as well.
ISPs are different at both places and their DNSs are different.

Hello Pavel,

I have a different problem reported and I see some similarity to my problem.

ROCK won’t connect to internet - Support - Roon Labs Community

I don’t have a Qobuz account. In my situation I think connection to Tidal is always primary reason for all delays. Search result comes back in 4 minutes, but following search results will come back in seconds. After every reboot Tidal login is taking so much time!

Can I ask you what you mean with Cisco commutator? Is it a switch or router? Or what is the model number? There was a common past of Cisco and Linksys together. Maybe there is a common design in those devices. In your situation you have two different locations and different ISP, but having Cisco in both setup.

Enjoy The Music!


I fixed problem with Tidal in Roon this way:
On Rock I connected to it via http and saw that IP address and DNS were given by DHCP. I wrote that data (addresses) to a piece of paper and turned of DHCP there and put information as IP address, Mask, Gateway manualy as they were when DHCP was used but instead of previous DNS address I put Apllied settings and rebooted ROCk. And Tidal started work nice.
With the ROON installed on QNAP I went to network settings in QNAP and added as a secondary DNS address. And again it started work nice.
A lot of people here complain on how ROON works with Tidal and strange that they cannot fix it… As it is obviopus problem of how ROON sends requests to DNS server…

1 Like

Hi Pavel,
I tried all these things like a fixed IP address (No DHCP) and changing DNS server to None of them worked . Many thanks for your update.
Enjoy The Music!


Hi @Pavel_Ezubov ,

Thanks for letting us know you were able to resolve this issue with the DNS change, happy listening!

But you really have to work on this issue as it seems that Roon sends requests to DNS server incorrectly or unusual as not all DNS servers can respond correctly to Roon. Tidal itself works fine…

It’s more likely to be the fact that Roon hammers DNS queries every 24 hours or so when fetching metadata updates from its cloud services. Not all ISPs are tolerant of this, which is why Roon Labs recommend the use of Google or Cloudflare DNS servers in such cases.

Here, for example is my Roon Core (at hammering DNS services during a 10 minute period starting at 16:00 yesterday:

I use Cloudflare DNS and have this problem with Tidal (through Roon) being slow, but Qobuz (through Roon) is fast/normal.

I think the changing of network config, DNS, etc. is a wild goose chase given the symptoms point to Roon not a local network or DNS issue.

For myself, I’m tabling this issue and just avoiding using Tidal (through Roon) until after the 1.8 update on the off-chance something in that fixes the issue.

I’m lucky enough to have free access to Qobuz, so I have this alternative; I feel for those who only have Tidal.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.