TIDAL login issue - 05.06.2020

Issue affects me as well („TIDAL login failed“ after each reboot).

  • Roon Core 1.7 537
  • Windows Server 2012 R2

Used to work fine in former Roon versions (before updates in April).

1 Like

Hello @Shibumi and thanks for reporting this. To help our team, I’ll need some additional information. Could you please reboot (so you get the “TIDAL login failed” message again) and reply here with a timestamps (your local time) when you do this? I’d like to enable diagnostics for your account so I can pass the report to our team. Thanks!

Hello @nuwriy, I did as you suggested and restartet the server with the following local time-stamps from today (11-May-20):

  • Server reboot: 18:44
  • RoonServer start-time: 18:46:40
  • RoonAppliance start-time: 18:46:41
  • RAATServer start-time: 18:46:50

I did not yet try to login to TIDAL.


Hello @Shibumi and thank you again for your report.

I have been discussing this issue with the technical team and we are aware of a few similar reports where users have to re-login to TIDAL upon Core reboot.

There is an active investigation in progress and QA is looking into what improvements can be made in this area of the login flow.

We appreciate your patience while this investigation is ongoing and apologies for the inconvenience of having to re-login when the Core is rebooted in the meantime.

1 Like

If it helps/matters, have experienced the same problem, for the last couple weeks, most recently an hour or so ago.

A few more facts and observations.

  • I am running a Pi-hole DNS-blocker (and have been doing so for about 2 years; and, as I noted in the first post, things used to work fine).
  • When the PC running Windows Server 2012 R2 boots and Roon services start there are “Warn” messages in the Roon-log saying "NetworkError:The remote name could not be resolved: ‘api.tidal.com’ "
  • However, at the times listed as timestamps in the Roon-log the Pi-hole log lists no call to api.tidal.com.
  • Moreover, after a reboot there is, according to the Pi-hole log, no call to any “tidal” web-address.
  • As soon as I “Retry” to login to TIDAL from the Roon error message there is a call to api.tidal.com in the Pi-hole log — and from then on things are fine.

Have you tried setting DNS to

In reply to @wklie I tried his suggestions and then some with respect to DNS on the Roon Core Windows 2012 R2 server:

  • With Pi-hole still in the loop, defined a secondary, outside DNS server ( and rebooted → problem remains.
  • Disabled Pi-hole completely, such that all DNS requests are transmitted unfiltered and rebooted → problem remains.
  • With Pi-hole disabled, defined as only DNS server and rebooted → problem remains.

Network traffic control showed that in those steps where Pi-hole was disabled indeed the traffic passed by.

I have the exact same problem. If I close Roon in Windows 10, the next time I open it an error message pops up stating Tidal could not log in. Then an Edge window opens and I click on my name on aTidal page and then I’m taken to Roon. Been happening for a week or so.

FWIW, the just release subversion 555 (ie 1.7/555) did NOT fix the TIDAL login issue.

Did you reboot EVERYTHING? Maybe then it will work. Maybe also, go to Tidal and sign out and back in one time.

Yes, I did. Logged out of both TIDAL and Qobuz, then logged back in, then rebooted the core machine and restarted Roon core. Same problems. No difference at all.

My library is fairly large (db about 12GB in size) and takes a while to load when the core restarts. Maybe Roon has a timeout of some sort with TIDAL and Qobuz? Both give me errors, though Qobuz eventually logs in when I “Retry” vs TIDAL requiring to open a browser to reauthenticate.

Bummer for sure.

Wanted to let you know that after the most recent update (now running 1.7 571) things have changed for the better. While there is still the ominous “TIDAL login failed” message after every restart, I can get rid of it with a single click on “Retry”. The message disappears and TIDAL connection is fine. :slightly_smiling_face:

Hello @Shibumi, and I’m glad we’re seeing some improvement. We’re still aware of this issue and working on more solutions for this area of Roon. Thanks for your patience!

I am having the same issue on a 2012 Mac mini. Any update for this issue?

The issue cleared out for me some time ago.

My core runs on a 2012 mini, i7quad, 16GB RAM, 250GB SSD + 3TB HD. FWIW, I am now running Catalina, but I seem to recall the issue cleared while I was on Mojave.

Hey @Adam_Sloan, are you running the latest version of Roon?

I am. The issue seems to have cleared itself up. My apologies for the late reply.