Tidal Masters MQA album identification via Lumin app

Yes, it does.

@wklie, When using Lumin streamer as endpoint (Roon Ready), Roon will take over the entire process, including decoding and DSP. If I understand correctly decoding must happen in Roon (software) not in Lumin hardware. Unless Lumin app is used, then all process will happen in Lumin itself.

So does Lumin decode MQA when used through Roon app or not?

You make it confusing.

According to the link @wklie provided, when a Lumin is used via analog out directly to Amp, full MQA decoding is done, even when used via Roon app?

No?

I’ve to wait for his reply. I understand when a device is used as Roon Ready, such as endpoint, Roon will take over all the processing. Not sure there’s a ‘provisional processing’ Lumin is taking about.

Roon sends bit-perfect undecoded MQA (via RAAT) to Lumin for Full Decoding. For this to work Roon DSP Engine has to be disabled.

Lumin MQA decoding should work with all its supported apps - Lumin app, Roon, JRiver, etc.

2 Likes

A few more words about processing. With DSP Engine disabled, Roon does not need to process the music file (other than decompressing FLAC / Apple Lossless to PCM) for playback, leaving the MQA decoding completely to Lumin.

When Roon adds MQA Core decoding in the future, additional options may become available and this subject will need to be revisited.

1 Like

Thanks @wklie ! it is clear now. Can’t wait for my T1 to arrive.

Any suggestion for a pass through, fully analog preamp just for volume control?

Peter…in the ‘Headroom Management ’ section is the Roon DSP Engine ‘disabled’ when the notation next to that area says…‘enabled’ or when it says’ disabled’…?it is a little confusing…thanks

@wklie
Thanks for the reply, this indeed a good news. Users of Lumin can get the best of Roon’s UI and full MQA decoding inside Lumin as one package!

In DSP Engine settings, please make sure DSP Engine at the top is “Disabled” and the slider is in grey for bit perfect playback. If it says Enabled and the slider becomes blue, the playback may not be bit perfect, depending on the various individual settings below such as Headroom Management.

Note: in Audio Setup menu it uses a different UI style for networked Roon Ready devices. If it says Enable (not Enabled) in blue color, it means the device is not enabled.

And don’t forget: a good quality DAC!

Confirmed: Lumin T1 does full MQA through Roon.

First impressions here:

Does it make sense that my T1 is clipping while playing Tidal MQA files? I have to set DSP headroom to -3 in Roon device settings.
@wklie

Did you hear clipping, or see the clipping indicator in Roon instead?

If you have other DSP options in Roon enabled such as convolution or EQ or upsampling, you might clip without headroom.

https://kb.roonlabs.com/DSP_Engine:_Headroom_Management

Dear @wklie

I solved the problem with distortion playing MQA files on my T1 by reconfiguring my network. Sounds fine now. But the display periodically displays PCM 48 kHZ 24 Bit then briefly displays MQA Studio 96 kHZ 24 Bit. Is playback actually changing?

I have confirmed that the same does not occur playing the same tracks playing Tidal through the Lumin app.

I have a Mac mini running Roon Core. Could it be that it doesn’t have enough processing power?

Any interest at Lumin in developing a Roon dedicated server?

I have recommended your products to everyone interested in digital playback.

Kevin

Firstly, please make sure Roon DSP Engine is disabled, and volume leveling is disabled.

It is normal at the beginning of playback of any MQA track to show PCM briefly before the MQA decoder locks on to the signal. It is also normal for this to happen if you change the playback to different time positions.

If the music has been playing for more than 3 seconds, and it’s not near the end, then a change of display is not normal. If this is associated with any click and pop, the track is corrupt or the firmware has a bug, and needs to be fixed. If this is not associated with any click or pop, this is a cosmetic issue, and may or may not be a bug.

To check whether your Roon Core is fast enough, bring up the Roon signal path during playback and watch the processing speed indicator. If it’s below 1.3 even when DSP is disabled, you need hardware upgrade.

We are not interested in making a Roon Core server. If you want to replace your Roon Core server, you may look at Roon Nucleus, NUC7i5BNH with Akasa Newton S7 fanless case and Sbooster LPS for NUC, or SonicTransporter.

Thanks! :smiley:

Dear Peter:

Thank you for the prompt response. Your suggestions helped me solve the issue. The Lumin T1 was grouped in a zone with a MicroRendu. Although DSP and Volume Leveling was turned off for both units, MQA playback blinked on and off in the Signal Path for the T1. I could not detect any real difference in sound quality; there were no clicks or pops. But unlinking the zone solved the issue. Must have something to do with the MR being unable to process MQA, yet. I will try zoning the two together when MQA update is released for the MR.

Yours truly,
Kevin

Grouping will destroy MQA integrity, no wonder you see the MQA locking blinks. Currently MQA (regardless of which brand of device) playback only works for a single device.

I’m not sure whether the future built-in MQA support in Roon will address that or not.

@wklie

Dear Peter:

Tidal MQA plays spectacularly using the Lumin app, but still getting drop-outs or distortion using Roon. I have dsp and volume leveling off. I have tested with identical tracks.

Could I have something else set improperly?

Kevin

Please also make sure it is not grouped with other endpoints when playing Tidal MQA.

Please try different Masters albums, different non-Masters albums, and the same problematic albums during non-peak hours.