Tidal not running or after long waiting since last Roon update


Since the recent Roon update with the new login method for Tidal, my roon/Tidal combination works in a very erratic way, not Tidal songs playing or after very long (minutes…) waiting times. Anybody who can help? thanks

Me too.
I can not play TIDAL since last Roon update.
I can not fix it.

Same here, could not solve it with the support

Same here…tidal initializing on roon remotes but won’t play.
Tidal does play on the core, however.

+1 here . How do I place a support call ?
Im a big Naim user and Tidal is working perfectly with the Naim app so its clearly a Roon issue

I hate to say it but me to. Tidal gets stuck on indexing in my case. I tried logging out cleaning the database and restarting roon before reinstalling. Still no luck.

It’s not working for me either. When I click on my favourites it says I don’t have any favourites. When I start to play a song I get an error message saying the song is not available on Tidal and that is happening on all songs I try to play.
I use the latest version of ROON (1.7 build 528 stable) on a MacBook Pro 2016 with the latest version of macOS. I have tried different things like restarting the computer, logging out and restart ROON and the logging in again in Tidal. Nothing helps and I can’t play any songs from Tidal via ROON.


Still same setup, since last 3 days, none of the tidal tracks play in Roon. Tidal alone works fine. Did anything change?