Tidal not working for me

So, I’ve had this problem for a while now, but I have mostly ignored it. Now it is starting to annoy me a whole lot.

So my setup is as follows, Roon Core is running on my QNAP TS-873 and I have three different endpoints, my Devialet 220, the small Ikea Sonos and a HifiBerry setup with digital outputs.

Also my Tidal subscription is for Tidal Premium not Tidal HiFi, if that matters, it didn’t use to.

So the problem for me is following, I start playing something from Tidal, the songs are added to the playlist and it just goes throught them one by one, skipping each and evey one of them.

I think before the previous Roon update it could also behave so that the songs were added to the playlist and it would just get stuck with the first song and nothing could be played on that endpoint until I restarted the Roon Core. The behaviour was consistent and happened with all endpoints.

Things I’ve attempted in order to remedy the situation. I’ve restarted Roon Core, I’ve restarted myö endpoints, I’ve logged out of Tidal and back in again and I’m beginning to run out of ideas.

Any pointers? Similar experiences? Something?


The symptoms you describe are often network related. What is your network setup including manufacturer, model and connection types.

Well my local files play well over the same network, but to be thorough…

My internet connection is fiber based coming to my apartment over ethernet, the first device it meets is my Cisco RV345 router. My NAS is connected directly to the router and has a static IP assigned to it by my router based on its MAC address.

I have a Apple Airport Extreme working as plain WiFi hotspot, but it is not between the NAS and endpoints, only Roon Remotes connect via that and the connection is working fine (Remotes are on MacBook Pro 2018, iPad Air 2020 and Samsung Galaxy S20).

Between each endpoint and my router there is a switch, every one of them are (cheaper end unmanaged) HP ProCurve switches.

In every (other?) use case I’ve tried my network is really robust.

Playing local files still works and even Tidal used to work. I’m not using jumbo frames, VLANs or anything special.

Ok, so it’s not better it just behaves differently at different times. Today I tried to play Jimi Tenor: Aulos from Tidal and Roon just didn’t play it, it got stuck before the first song. I tried to play local files after that and Roon seemed to change the now playing accordingly but nothing would play. Only way to get around the problem was to restart Roon Core on my NAS.

Any ideas @support

Hi @Janne_Johansson,

Just to confirm, does this happen for every endpoint? If you play TIDAL content to System Output of a remote do you see the same issue?

In the past we’ve seen TIDAL performance be impacted by DNS issues stemming from ISP provided DNS solutions. Can you try switching your router to use Google DNS or Cloudflare DNS and let us know if that improves things?


Thanks for the suggestions.

The behaviour seems to be the same with all endpoints. I tried enabling the System Output on my MacBook and play there but same exact problem.

I changed the DNS servers on my router to use Google DNS servers and no change. Also the standalone Tidal app and Tidal from within a browser works flawlessly.

Hello @Janne_Johansson, could you please reproduce the issue one more time and reply here with a timestamp (in your local timezone) and the name of the track you noticed the issue with so I can enable diagnostics for your account?

Sure. It happens with all the tracks I’ve tried but now at 18.43 I tried playing the song Sugar and Spice by Jimi Tenor.

Hello @Janne_Johansson,

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Ok, so the problem still persists, but it looks like playing to Ikea/Sonos it’ll just skip the songs, but playing to Devialet will make it get stuck and require a restart of Roon Server before being able to play even local music on the Devialet.

Hello @Janne_Johansson, and thanks for your patience while I discussed this issue with the QA team. We noticed that you’re using a VPN router, which might cause issues similar to this. Could you please disable the VPN features on your router and let me know if you see an improvement.

I’d also recommend, if possible (and disabling the VPN features doesn’t yield a result) that you try a different machine as the core temporarily and see if the issue can be reproduced.

Thanks for the suggestions. I tried going through myt Router settings, but I had no VPN stuff configured. Well I knew that but I had to check. I also downgraded my router firmware just in case but no help. I’ll try running the Core on a NUC I have lying around at some point to see if that makes a difference.

Hi @Janne_Johansson,

Definitely let us know if trying out the other Core helps here! That would definitely be a good test to help rule out some variables here.

Just an update, the problem still persists even with Roon 1.8. I’ve been busy with other stuff but will most likely try installing another Roon server in the coming week and move it around in my network to see if that changes things.

I’m still pretty curious as to what Roon is doing that is so fragile it could break by passing through standard network equipment. Tidal is working fine on its own, local streaming is working fine, it’s just the traffic from Tidal to Roon (or Roon to endpoint, even though streaming local files works?) that is not working. And Roon has some kind of connection to Tidal since it’s recommending stuff from them. Weird. Well, I sure hope the experimentation with the other server helps solve this issue.

Ah, ■■■■■

So the problem was my Tidal Premium subscription and lack of aac support in QNAP’s ffmpeg. A know problem but apparently not to me. Well at least it works now. Solution was here:

I even built my own ffmpeg before I found that. Better go with the solutions readily available.

Sorry about the hassle.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.