Tidal visible but won't play

Tried to play from Tidal today with no success. Tidal is visible, along with all my playlists that contain Tidal tracks. When I select a track, and it’s the first of 5 tracks in a playlist, Roon says “Playing 5 tracks” even though I only selected one track to play but nothing plays it just hangs. Tried signing out and back into the Roon account in Tidal, no difference. When I re-boot Core I it will play 1 or 2 tracks and then it hangs again.

This is the default behaviour for playlists, it plays all tracks in the playlist starting from the one selected.
To play just one track, right click or long press and then press the blue play button.

Now this of course is not right.

  • Is the problem only with Tidal tracks?
  • Do the Tidal tracks play using the tidal app?

Yes the problem is only with Tidal tracks. Tracks play fine in Tidal app
or on any other Tidal enabled device, for example Naim Superuniti.

Thanks for the update, let’s drop tag for @support to follow up with you.

For some reason today, Tidal is visible in Roon but everything I attempt to play gives an error message saying that ‘this track is not currently available from Tidal’.

I can log in to Tidal app and play the same stuff, so my account is ok and the music is definitely available, just not through Roon. I checked Roon settings and it is logged into my Tidal account ok, but no music at all is currently available.

Is this a problem with me alone, or have others had a similar experience?


Try removing your Tidal account from Roon completely and then setting it up again.

Hi , I had the same problem. I logged out of Tidal , logged back in . I rebooted the main PC , still same issue. I rebooted the squeezebox and now everything is working again . Hope that helps. Tony


I logged out and back into Tidal within Roon and all worked ok again.

Thanks for replies.


1 Like