Tired of restarting 1.8 to use endpoints

Roon 1.8 Crashes several times PER MINUTE.
iOS iPhone app crashing like crazy. when trying to use… not linked to any specific Roon function.

quits completely (not a freeze).
iOS 14.4 iPhone 12 Pro.

My devices have disappeared 3 times since the update to 1.8. It was frustrating the first time since I didn’t know the solution since then it takes all of 3 minutes to restart the Zen Mark 3. First-world problems.

Although it’s an issue, I don’t see why anybody would start yet another thread to complain about it after Roon announced it was working on the problem and would probably issue a fix early next week. Unlss Roon’s fix fails, a couple more days of patience should be rewarded.


@Brad_Burnside Can you place your Roon Core on an alternate device. I’ve used an imac desktop for almost five years, and for the most part it’s been trouble free. Only issue was the Apple Catalina rollout, and I just shifted the Roon Core to a laptop PC until they fixed the software bug (external music storage was rendered useless). If you can temporarily shift your Roon Core, that could be a good temporary fix.

My devices are also disappearing!

Thanks, David, for your reasonableness. We do crave calm.

I was just spleen-venting late last night when I had to restart the server for the umpteenth time…

1 Like

Happening to me as well. My core is running on a nuc. My endpoint is a Sprout connected via USB to my win 10 desktop. Shows up in the audio setting but not in the room zones. Restarting the core machine fixes it. Doesn’t happen every time but enough to be anoying.

This IS most definitely a Roon 1.8 issue. With 1.7 I NEVER had any issues with endpoints disappearing. Since 1.8 I am restarting ROCK almost daily. Too many people are reporting this since 1.8.

I’ll bet Roon knows nothing about this problem and is not testing a fix to be rolled out next week. Maybe we need some more post on this issue (Sarcasm, if you can’t tell).


Your bet is off :wink:. Read the threads.The Roon team is already aware of the issue and investigating it.

It’s sarcasim. They have a fix for it and have announced the fix will be rolled out early next week after testing is completed.

1 Like

People can not see your face when you write it. Also most people don’t know you. No way of telling if you are serious or not. Unless you do not clearly indicate it is sarcasm people have no way of knowing it, because to them it is only some black letters on a white background.

They know if they have been around here for a day or two. And if they don’t, so what? This problem has been reported since day one and has been reported over and over. Roon has announced a fix is being tested and will be rolled out early next week. A simple search before posting would show this.

Yes they would know that is reported over and over. But they still would not know if you where sarcastic or not, because they don’t know you. But I do not want to bicker. Have a nice day.

1 Like

Dipping my toe back in here to tell of my workaround, others have confirmed it worked for them.

The zone becoming unavailable was happening to me every time I turned my dac off that was connected via USB.

The workaround is to enable an additional endpoint on your streamer that won’t go off, in my case I had a Pi, and I enabled the default audio out in roon and made it a private output so it didn’t show up in the client apps. Since doing this my USB connected dac comes back as soon as it is powered on.


@Andy_L is new here @Jim_F He hasn’t met you yet… :smiley:

I would cheerfully award you the sarcasm badge… :laughing:


Thanks Robert, I try.


Now I have met you :grinning:. Nice to meet you @Jim_F! Your sarcasm will be appreciated from now on :wink:


I have a fresh install of Roon 1.8 (since I’m a new roon user).

My 5 Sonos endpoint are always connected. They never have a problem.

My iOS device never has a problem.

My Ropieee with a Gustard x 16 DAC sometimes will fail to be selectable. This happens if I turn off the Ropieee and the DAC. When I turn it back on sometimes the server just doesn’t see it.

The worst offender is the Windows client. If I leave it running and put the computer to sleep 9 times out of 10 the server just won’t see it when it wakes up. If I turn the client off then sleep the computer same thing.

It has something to do with clients being disconnected.

It’s clearly a roon issue. It’s a vanilla roon setup with literally 0 customization.

I’d like to state that it’s easily reproducible.

I’m a network engineer. Itook a look at what’s going on under the hood. Roon uses some kind of weird non standard multicast type setup. I can watch the clients broadcast (I’m here) and the server does not respond.

Restart the server and it immediately responds to the clients broadcast.

The network that the clients and server on is nothing special. Hardwired via gigabit ethernet to a single switch that the server is on. Nothing weird or funky.

1 Like

Worked for a bit. But not for very long.