Topping D70: Roon lost control

I have the latest RopieeeXL installed on a RPi4 connected to my Topping D70 with a Supra USB lead. After a few seconds of play the message ‘Roon lost control…’ appears, initially I thought it was related to using the Pi’s USB 3 port so moved it a USB 2 but that didn’t help.

In a moment of desperation I decided to use a small 2 port passive USB hub and it worked, no disconnects, stable at DSD256.

Any suggestions as to why the passive hub works and a direct connect doesn’t?

What other USB cable are you using? Try that direct between the two devices.

Hi Henry, I’m using a Supra 0.75m USB lead and was directly connected that to the DAC, this resulted in the ‘lost control’ messages.

So have you tried a different cable?

Hi Henry, now that’s odd, plugged in a perfectly ‘normal’ USB cable and it works fine, no ‘Lost Control’ errors, no more…

[ 586.188104] usb 1-1.2: USB disconnect, device number 6
[ 590.592689] usb 1-1.2: new high-speed USB device number 7 using xhci_hcd
[ 590.723448] usb 1-1.2: New USB device found, idVendor=152a, idProduct=8750, bcdDevice= 1.04
[ 590.723490] usb 1-1.2: New USB device strings: Mfr=1, Product=3, SerialNumber=0
[ 590.723521] usb 1-1.2: Product: D70
[ 590.723545] usb 1-1.2: Manufacturer: Topping
[ 590.762104] usb 1-1.2: 1:3 : unsupported format bits 0x100000000

…messages. No need to use a simple passive hub. What’s going on with the Supra USB cable?

Thank you for forcing me to check the cable :slight_smile:


No problem. Your issue isn’t as uncommon as you might think.:slightly_smiling_face:

1 Like

Yet another boutique just-for-audiophiles failure. Digital superstition.

My thoughts too Bill, I’ve always doubted digital cables, it was an experiment hence a cheap…ish, short length, what could go wrong with two plugs, 4 little wires with 2 carrying data?

Time to stick with a standard Belkin me thinks!

1 Like