Track titles: Mixes appear as sentence case?

I’m new to Roon, so apologies if this should be obvious to me and isn’t. I have a NAS drive with all of my music files ripped to ALAC in folders. I’d already invested a considerable amount of time grooming my file names, and was disappointed to discover that Roon appears to use sentence case for any mix names, e.g. Heart of Glass (Diddy’s adorable illusion mix) vs. Heart of Glass (Diddy’s Adorable Illusion Mix).

I know I can go in and select the option to use my track info per CD and I did that once as a test (took a while to find that option), but is there any way to make this a universal, whole system rule? Otherwise, what seems like a small detail is really a large dealbreaker for me.



Hi John,

You can select all albums, go to Edit, then to metadata preferences and change them for all the selected albums in one go. This will correct the albums in your library. Then go to Settings Library, Import settings and select the track title to prefer file. I think that will work. Not at home to test it.


Thanks, Daniel. I didn’t see where I could select all albums, but I navigated to the Library settings and changed the preference there. Seems to be rescanning my library now, so we’ll see if that takes care of it.

Am I correct in that Roon prefers sentence case for some reason re: mix names? It’s an odd preference.

I’m not quite sure.

As to selecting multiple albums, if you select 1 album, in the top right you will see a “1 selected”, this is a drop down, and under the drop down there is a Select All option. Also, in Windows Ctrl-A works.