Tracks will not play

Core Machine (Operating system/System info/Roon build number)
QNAP 472XT (Linux based)
App Ver: 1.7 (build 667)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
LUMIN T2 connected by Ethernet

Description Of Issue
First time user of Roon.

I’m finding any file I select to play from my Qnap NAS drive refuses to play. The information appears on the LUMIN t2 but will not play.

I think I’ve managed to play about 2 tracks from several hundred. It’s not consistent.

My account with Tidal has exactly the same problem too.

Choose any artist from Tidal and the track info comes up on the LUMIN display but will not play.

Am I missing something silly here?

Thanks in advance

Before using Roon, did you have any problems with using Lumin app to play to T2?

In Roon, please check whether the analysis has completed in Settings -> Library.

Please try adjusting Audio Analysis settings and see if it helps:

At this time, QNAP has an issue with AAC playback in Roon. Please play any music that is not in AAC format.

In Tidal, make sure you have the HiFi account instead of the Premium account, and try playing FLAC files only, not AAC.

Thank you for responding Peter

The library has been up and running for several weeks so I don’t think It’s related to analysis.
You did touch on something though regarding AAC and I assumed it was that as it would play certain tracks and that was the common denominator

As for Tidal. I’ve only ever had the Hifi account but it’s difficult to tell within the Roon app what is FLAC without selecting a track to play and it shows up on the LUMIN. Whereas the tidal App tells you this information. Is there something I have missed in viewing track information from tidal (or any other service) within Roon app?


I thought I had fixed it by refreshing the app within Qnap. It started playing any track I wished from Tidal.
As soon as I switched to Qnap (Roon Server) library, everything stopped playing again, including anything from Tidal.

So frustrating as I really like the idea of this but I’m loathe to join up with life time subscription if this happens.

Basically, if I bounce the Roon server service (does this as part of a update check) it allows me to start playing from Tidal again.

Do you mean refreshing the Roon app package in QNAP app center?

I don’t understand this - what do you mean by “switch”, since I think there’s only one Roon (Server) on your QNAP. Or you mean you switch from Lumin app to Roon Remote app? Please clarify.

Do you have another computer that you can use to run Roon and transfer your license there, at least temporarily? If another computer works, this proves the fault lies in the QNAP Roon installation, or the QNAP itself, then we can try to work on what went wrong with the Roon QNAP installation (despite its AAC limitation).

I only have one Roon server.

At present I do not have another option for setting up a Roon server on another computer.

When I say “switch” I’m referring to source. As soon as I switch from using Tidal source to music files stored on my Roon server, the process stops. I can no longer play any tracks from any source until I restart (bounce) the services on the Roon server. Be it Tidal or local files held on my Qnap (Roon server ).

So there is obviously something inherently wrong when accessing the data on the Qnap. Possibly some corrupt files? I’ve ran the cleanup utility. Unless there is something else I should be doing?

There are three possible interpretation of Tidal source, please confirm:

  1. Roon being used to play Tidal
  2. Lumin app being used to play Tidal
  3. Tidal app being used

If you’re meaning 1, please check your QNAP SMART HDD reports. If you can get the details SMART reports, post it and I’ll check them for you.

For cleaning up, there are:

  • Library Cleanup
  • Clear Cache
  • Regenerate RAATserver manual procedure

I’m only using the Roon app. I don’t recall mentioning using anything other? I login to my Tidal account through the Roon app.

There’s nothing to be misinterpreted as far as I know? I use the interface with Roon app to switch between my local library and my Tidal account.

I will try your suggested cleanup on the NAS.

On another note, I see still no response from a Roon representative after a week. Poor show if they’re trying to sell a premium product.

No offence to you Peter. You have been most helpful.

On another note the Roon app now constantly crashes every 15 seconds on my iPhone 11 plus. Completely unusable now to change tracks etc.

To be fair, it’s been less than two working days. And they could be waiting for the clarifications I asked about before joining, and/or waiting for the results of some steps:

To reiterate:

  1. Please post detailed SMART HDD reports
  2. Please do Library Cleanup in Roon settings
  3. Please clear cache in Roon settings
1 Like

Hi Peter.

I refreshed the Roon folder structure (RAATServer) as instructed as well as cleanup but finally narrowed down to AAC files. You did make an initial comment regarding this.

The QNAP (TVS-472XT) is reporting no disk errors but happy to provide smart reports later.

I find when attempting to play any AAC file, the Roon core locks up and I have to restart the Roon server service to allow me to stream anything else.

I found this recent article and looks like QNAP firmware compatibility is to blame??

There are a few threads giving the solution, it appears qnap supplied a version without the right CODECS in.
You need to update the qnap as you have found.

1 Like

Sorry Peter

You did give me the solution in the first response.

I just failed to see it. I only have the odd 5 min over the past few weeks to look at this in between my busy day job. So apologies.

But it was a worthwhile process as had a lot of “crap” on the NAS with old corrupt media files. So now have a clean database to start from.

I will update the QNAP firmware. It does have the latest but presume there is a beta release somewhere.

Installed the latest decoder files for FFmpeg and bounced the Roon service.
Also uninstalled Roon from my iPhone, rebooted and re installed. All stable now. No further crashing off the iPhone app for now.

Normal service resumes.

Thanks @wklie @ged_hickman1


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.