Trouble getting Roon Arc to work

Roon Core Machine

Roon Optimized Core Kit, NUC10i3FNHN, Core i3 10110U / 2.1 GHz, 32 GB RAM

Networking Gear & Setup Details

Amplifi HD, Connected via ethernet av devices are conected via WIFI, no VPN

Connected Audio Devices

Plays to Roon ready devices mostly Lyngdorf TDAI1120

Number of Tracks in Library

20334

Description of Issue

I cant seem to get the Roon Arc sftware to access the roon core. Here is the error message:
{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

Hey @Henrik_Borge,

First off, welcome to the community! We’re excited to have you here. Thank you for reaching out for assistance with port forwarding.

Typically, errors like the one you see can be caused by a misconfigured Port Forwarding setting, if you are not seeing Ready listed in Roon Settings -> Roon ARC, please look over this guide before proceeding.

If you have reviewed this guide and still have not resolved the issue, can you provide the following details about your network setup to help expedite troubleshooting?

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

  5. How is your Roon Core connected to the internet?

Thanks!

  1. Who is your internet service provider?
    Telenor

  2. Please list the make and model of your modem and router?
    Router: Amplify Router HD Modem: Telenor Modem VM3000G-TCMNI

  3. Do you have any additional network hardware, like additional routers or managed switches?
    Yes my personal router goes trough another router and modem for the rest of the house.

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
    It has a firewall

  5. How is your Roon Core connected to the internet?
    Via ethernet cable.

Hey @Henrik_Borge,

Thanks for letting me know. In a situation like this, you’ll need to set your modem to bridge mode, on top of setting up port forwarding on your router. Here is a breakdown on setting up port forwarding for your specific router:

With this, I would also make sure that you’ve either made an exception for Roon to pass through your firewall, or to temporarily disable your firewall to test if that may be the blocker here :+1:

Thanks!

thanks for the help so far, but what do i write in the port forwarding rule?

Hello @Henrik_Borge,

Before you start with the port forwarding. In the Roon App under Settings → Roon Arc write down the IP address and port number shown there.

As shown in the instructions in the link provided by @benjamin you need to give your port forwarding rule a name, ie. Roon Arc.
In the IP Address field, enter the ip address you wrote down.
In the Source and Dest. Port fields enter the port number you wrote down.
As portocol select TCP (that’s what Roon Arc needs, i read that some people need to select UPD also).

Then click Save (it a “V” shaped sign in the top right corner).

Hope this helps.

Kind regards,

Maarten.

1 Like

Thank you, i have done as described in this tread. Set ut port forwarding on my amplify router and put it in bridge mode. And now it seems i cant get into normal roon. The program just says “Remote conection waiting for roon core”. I guess the modem or the other router wil not let me get into roon. Ive tried to test this by conecting to an lyngdorf amp via its ip adress and that wont let me in. Do you think its i firewall setting?

Did you put your modem in bridge mode?

Maarten

Aha! Sorry, i misunderstood i put my router in bridge mode. I don’t know i i can put my modem in bridge mode but i will se if i can.

Hi @Henrik_Borge,

No problem! That’s the idea, your modem in bridge mode.

What model is it?

Kind regards,

Maarten.

1 Like