Trouble installing RoPieee on Magna Mano streamer

Hello all,

I’ve downloaded the latest image, flashed to an 8GB micro SD card, inserted into the Pi board and booted the device. I noticed the fast flashing green led and then after after a couple of minutes I get a 1 second on, 1 second off flash.

I can ping the device, but when I point a browser to it I get this error:
Cannot GET /cgi-bin/about.cgi

So I pulled the device apart so I could get to the the HDMI port, connected a monitor and video’d the ARCH Linux startup sequence.
I get one red FAILED:
Failed to start Grow File System on /.
See ‘systemctl status system-growfs@-.service’

All else goes OK.
The last line I see during boot is:
Started Network Time Service.

Then the screen goes blank and a get the green LED flashing for a second every second.

Any thoughts? Any help at this point would be greatly appreciated :slight_smile:

I think you’re approaching the wrong webpage. RoPieee’s webpage is not using cgi.
The loggings on the console are harmless.

Have you tried going to: http://ropieee.local/ or http://ropieee/


Thanks Harry.

Neither of those host names can be resolved.

I see the device in my routers network map as “ropieee”. From there I can get the IP address as assigned by DHCP.

I can ping the IP address and I get a response. Browse to it and I get the “Cannot GET /cgi-bin/about.cgi” error.

Could it be that ropieee was not fully installed? It only took a few minutes before I got the slow flashing LED. And I did not notice any rapid flashing that would signify a reboot.

During ARCH boot, I do see a line “Started RoPieee Web Page” on the consoleRopieee .

Installation does only take a few minutes.

I really don’t get the ‘cannot GET /cgi-bin’ message. Have you tried browsing to the IP address directly? Which browser are you using? And are you using the latest image?

And maybe the most obvious one: have you tried a reflash?

Yes - I’ve reflashed twice using Etcher. Etcher reports success.

I can only connect using an IP address. Not host name.
Ping is OK.

Unbelievable. I was using Chrome. I just tried using IE (spit) and it works!!!

Crisis averted :slight_smile:
Thanks for your time…

Chrome works fine, so there must have been some other issue impacting you. Glad you are up and running.

I thought now that I am getting the correct Ropieee web page using I.E., I’d try again with Chrome. No go. All I get is “Cannot GET /cgi-bin/about.cgi”.

Firefox also works without an issue.

Merry Xmas all.