Trouble with HQPlayer/Roon Integration

Reading the instructions I’m supposed to go to the networked under audio and click “add networked Device from the drop down menu”. I don’t see a drop down menu from the Networked section.

What am I doing wrong?

Thank you


It’s possible you have not enabled network control on the hqplayer side? I believe it’s a little globe at the top right of the main toolbar (could vary depending on os, not sure).

Hey George,

Adding HQPlayer has moved to the Setup menu since Roon 1.4 (Roon Settings > Setup):

I guess the Knowledge Base is not up to date yet – can you provide a link to the instructions you’ve read?


Here is the link

Thankyou it is setup, now the real work begins!

Thanks George – I’ve notified the Scribenti Rooni.

1 Like

Well now I can’t get any audio - it will play when I choose my OPPO as a zone but not when I choose HQPlayer.

Is HQ Player working by itself ?

It will play the files - I don’t have an audio output on the computer so I don’t hear anything but it shows as playing on the interface.

When you send audio to an HQP Zone in Roon then the audio output to a DAC or NAA is handled within HQP. HQP does not Output to Roon Network Zones, but has its own network client called NAA (Network Audio Adaptor). If your DAC does not support NAA then you will either need to directly connect it to your computer or insert an NAA device in your network prior to the DAC.

You then select a direct connection or NAA in HQP/Settings. Once you have HQP outputting audio by itself then Roon input should work.

You can find some tips about initial setup of HQP in this Kick start Guide.

What is your endpoint ?

It’s an Oppo 205.

The Oppo 205 is Roon Ready, but HQP doesn’t output to Roon Ready devices. You will need a direct connection to the computer or an interposed NAA device.

Thankyou I’ve reached out to OPPO tech support to find out if they support NAA.

FWIW, the Oppo is connected to the host by Ethernet.

So it is hooked up by Ethernet through a router. Do I still need another device?

I don’t think the Oppo will support NAA, not many DACs do. I use a microRendu as an NAA, other off the shelf options include a SonicOrbiter SE. DietPi can now load an NAA, so any device that runs DietPi can also be used. An Allo DigiOne or USBBridge, running DietPi on a Pi3 are good quality inexpensive options but require some slight setup compared to the SonicOrbiter SE.

If you can run a USB, Coax or HDMI cable from the computer to the Oppo then that will enable you to output directly from HQP before considering adding an NAA device.

Hmmm I have a couple of rpis on the shelf - will one of those work if I flash it with the right software. Will their be any audio degradation ?

A Pi with DietPi can be configured as an NAA. The USB out on the Pi is on the same bus as the Ethernet, which limits bandwidth, and is not well isolated from noise. For this reason people often add an S/PDIF board or further USB output. Try it out by itself and see what you think.

This from OPPO support, makes me wonder if I connect the computer to the OPPO via USB will that work? I’m guessing not…but have to ask.


How is the HQPlayer connected to the UDP-205? If you are trying to use the Asynchronous USB, then you need to make sure that the HQPlayer has drivers which can see the player as an external DAC solution.

Yes, that should work. I’ve referred to that as a direct connection in the posts above.

1 Like