Trouble with Roon ARC - Unraid - UDM

Roon Core Machine

ROON SERVER(latest version) on Unraid in my home server (2x Xeon 4210 , 128 gb RAM)

Networking Gear & Setup Details

UDM PRO ( firmware latest version ) , USW pro 24 , ethernet cable between all of them

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Hello,
I have issue with the Roon arc. I tried all the possible solutions ( UPNP activate/deactivate ,port forwarding , disable/activate firewall etc. ) but most of the times the message is the same .

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

Regards

I have the same issue ! [ ISP Modem/Router (Modem Mode only) to UDM Pro to USW Pro 24 to Server-Unraid-Roon Server ] . I tried everything and it doesn’t work .

Hi @Athanasios_Stamatis,

Thank you for posting, and I appreciate your patience as the support team works through port forwarding setup issues encountered by new users in ARC. We’d be happy to assist you. Provided the managed switch is correctly configured to pass the Core’s IP to the router, then your situation is likely caused by a second layer of NAT, either in your network or at the ISP-level.

First off, who is your internet service provider? If you’ve correctly enabled Bridge mode and UPnP on the Dream Machine, then we’ll want to check whether the service provider has implemented some sort of carrier-grade NAT.

As per @connor please advise on the ISP provider.

In the meantime, did you enabled NAT Port Mapping Protocol when enabling UPnP. Also select Secure Mode.

Also ensure your ISP box is in Modem Mode/Bridge mode like already advised.

Your USW Pro 24, are the ports your using for Roon and endpoints, device with Roon Remote all in the same range. Not on different VLANs.

Doing this will instantly work. If not, yeah it’s probably a ISP CGNAT issue.

Hello , My internet service provider is Cosmote/Greece maybe have some sort of carrier grade NAT ( I don’t know honestly ) …
In other applications such Plex(movies)/Plex Amp(music) works perfectly outside my home network . I tried almost everything and I am afraid that if I change something I will cause a problem in my network and my setup .

Hello , thank you for reply .
Yes I enable all of them and I make also combination of them . Yes my modem/router from the carrier is in bridge mode only and I am using only ubiquity gear to manage my home internet . Yes the all the Roon stuff is in the same network .

From a quick search on Google it is suggested your carrier is CGNAT.

1 Like

If your ISP is CGNAT which they provide you private IP. For Roon ARC setup, you need a public IP, please check with your ISP if they can switch from private to public IP as for my ISP, they switch for me at free of charge. Hope it helps.

3 Likes

Hi @Athanasios_Stamatis,

As advised by @Auron_Lim and @Lewis_Menzies1, you can inquire with your service provider is there is a workaround available for their IPv6 implementation or carrier-grade network address translation.

You can pass along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?
1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.