Troubleshooting Linux USB Sound

Hello, just setup the Linux server 1.2 on Ubuntu 15.10 server.

I can play to remote zones, but I am not getting sound to the local system/DAC.

I am using a KingRex UC192 to SPDIF converter. This formerly worked under Roon windows with ASIO4all.

Fiddling with a Linux desktop I could get sound to play through the driver, so I know from that and internet posts that linux sound is supported with native drivers for KingRex.

Are there troubleshooting steps and or an links you can point me to?

Thanks much,

If the device supports asynchronous usb it should just work, no drivers required…that’s a Windows thing.

Do you have Roon Bridge installed on the Linux box?

I do not – just the server. Do I need the bridge to play locally?

Not if you have Roon Server installed.

On Linux Roon plays through Alsa.

What does aplay -l say?

Here is the output:

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD1884 Analog [AD1884 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 2: AD1884 Alt Analog [AD1884 Alt Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: DAC [KingRex UD384 async-USB DAC], device 0: USB Audio [USB Audio]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

So Linux sees your DAC connected to the machine. Does it show up as an endpoint within Roon?

It does. I can select it and it shows as playing, but no sound…

Please screendump it’s settings.

I had trouble getting it to work in WASAPI under windows, used ASIO4ALL. Might be a device issue…

Don’t see any reason you shouldn’t be getting sound. Try setting volume to fixed and ensure your preamp volume is set appropriately before pressing play.

Thanks – tried that but no luck.

I pulled the USB converter out of the loop and plugged into a USB input on a DAC. That works. I think it might be a hardware issue.

Thanks for the help!