Trying bridged ethernet connection again

Hi: I have a Nucleus and I tried to set a dual ethernet connection between the Nucleus and my Bartok DAC using @danny’s suggestions at the thread below:

Specifically I reset the IP for my Nuclus to and netmask to The other two items Gateway and DNS I left blank. However, the Nucleus disappears from my network when I do this and Roon Remote is no longer able to find it. This is after I have made sure that the Nucleus is switched on. The ethernet connection seems to be fine too with one light under the RJ45 connector blinking and the other light steadily on. But my Roon Remote cannot find the Nucleus. I have tried choosing Help and typing in the IP address I created, i.e.,, but no luck with that either.

I am now thinking I may have to do a hard reset to get my Nucleus back to the automatically DHCP supplied IP address and go back to using my Cisco switch. This has happened to me once before and that was the only way I was able to fix things then. But before I do that, this time I would like to make sure I am not doing anything else wrong.

I have Verizon FIOS coming into the bedroom, and then a coax cable from the main FIOS modem running into the living room where the audio setup is. The coax cable runs into an Actiontec MOCA Adapter for Ethernet Over Coax, 1 Gbps Bonded 2.0 MoCA Adapter situated in the living room with the audio gear. An ethernet cable from the Actiontec is going straight into my Nucleus. Previously I had the ethernet cable running into my router of course and that has worked fine for a long time. FYI the Actiontec is this item:

Thanks for any help


How to reset Nucleus network:

Does the Nucleus even have two Ethernet ports? I can’t see anything wrong with @danny’s instructions – if prerequisites are met and instructions get followed things should work. Have you tested the proper working of your MOCA adapter using a common PC or laptop first? Is your Bartok DAC connected via Ethernet to your Nucleus?

Thanks for your help again @BlackJack . Yes, I have these instructions bookmarked now and will use them as soon as I get hold a keyboard with USB connection. That will be tomorrow evening.

No, the Nucleus does not have a second ethernet port. The approach is to use a USB to ethernet adapter. But I don’t believe the adapter is a problem because it is supposed to be used to connect to the Bartok.

The Nucleus’s sole ethernet port is the one to connect to the MOCA adapter. Yes, that woroks perfectly before the IP is reset, and has done for the last couple of years. But once the IP of the Nucleus is reset to it just disappears off the network. The IP address of the Bartok does seem to get reset to as stated in Danny’s instructions although I can’t remember checking this as I got a little sidetracked by losing sight of the Nucleus. I can try it again tomorrow.



The Nucleus needs to stay connected to your network (the Ethernet port on the back of the unit) so you can use it. I don’t know if the Nucleus supports USB to Ethernet adapters at all and if, which ones. If you connect yours, is a second tab for network settings showing up in the Nucleus web administration page? If not, the prerequisites are not met and Danny’s instructions can’t work for you.

Thanks again @BlackJack . It is possible I set the wrong ethernet port of the Nucleus to the new setting. I will try it again after resetting the Nucleus tonight, and look for the second ethernet port as some people seem to have found it with the NUC at least if not the Nucleus.

I believe the USB ethernet adapter I am using is the same one that someone recommended for the NUC.
ROCK Dual Ethernet - Primary Port Not Exposed [RESOLVED] - #42 by TopQuark.

Here is a link to the one I got on Amazon, same as above:


Tried this again but didn’t work. Perhaps the reason is that I need to set up the drivers for the USB ethernet adapter. Where do I check which version of Linux is installed on my Nucleus? I have a Nucleus v1.0, serial #94C691115A93.

I see from the website of my Plugable USB3.0 Gigabit adapter manufacturer that: “Linux kernels 3.8 and earlier require rebuild of kernel module from source. Recent distributions running 3.9 or later should have the driver built-into kernel.”


The Nucleus is an appliance, you don’t have access to the OS and thus can’t install anything on it. Hardware is either supported and just works or not (and you’re out of luck in this case).

1 Like

Thanks very much once again @Blackjack. That makes sense.