Turn off Private Relay in Monterey

… and it might help with Tidal woes. Worked for me today.


This should be general advice anyway, apple should stick their bloody nose out.

That being said I assume you are referring to those running a server from mac?

My goal is to help those who have had the Tidal issue. It concerns those using the Monterey beta with a Mac computer as a Core for Roon. When using an Apple beta one signs the terms and condition agreement. Roon has been clear they do not address mac beta issues. Apple has not injected their “bloody nose” anywhere in this conversation.

Indeed so its running the server, I can see how apples VPN could effect. It effects every other internet usage as well making the experience very poor. Hence why I said they should keep their nose out.

Private Relay hasn’t caused any problems for me (same download speeds, jitter and latency on my connection) so I’m not sure your experience is a general one. I don’t use Tidal, so can’t comment on that problem, but in all other respects Private Relay hasn’t caused any issues.

Humm don’t agree there I am afraid, any VPN is going to have an effect on speed and the internet is certainly in agreement. I have switched it off on my two laptops and iphone.

You can agree or disagree, but it has no relevance to the fact that Private Relay has no significant impact on my reported ping, jitter and download/upload speeds. YMMV.

With it turned on:

With it turned off:

A coupe of things to keep in mind:

  • Private Relay only applies to Safari and does not work with other browsers or apps
  • Private relay is not a VPN, it’s dual proxy service, to obscure your IP address from the destination website.
1 Like

Thanks @GregW, that certainly explains why I didn’t see any difference using the Speedtest app. I’d assumed it was system wide, but clearly not.

FWIW, I also had the Tidal issue. Did not pay attention to how to configure or enable/disable Private Relay and hence went with the defaults that came with the install. Because of unrelated problems switched off Private Relay in WLAN network settings (not iCloud). However, this didn’t disable Private Relay completely. Only found out today that it is configured and should be disabled in iCloud (see screenshot in @DaveN’s comment above). After disabling in iCloud settings, retried to play music from Tidal and it worked now - after being useless as long as I have Monterey installed.

I also suspect - but haven’t done quite enough testing to confirm - that Private Relay doesn’t play nicely with last.fm integration. That said, it is still in beta, so hopefully Apple will iron out the problems fairly soon.

Thank you so much. This was driving crazy. I tried only to play on my core - Imac (built in output). And even in that simple setup Tidal failed in Roon. But now I am good - I can live with the few seconds of delay between numbers :grinning: