Ubiquiti Dream Machine Pro and Roon ARC

I have Ubiquiti Dream Machine Pro and I am getting this message. Roon ROCK on a NUC. I have turned on UPnP.
{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“99.130.251.67”,“router_external_ip”:“192.168.1.136”},
“status”: “status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.0.1”,“found_upnp”:true}

I had the same problem with mine. You need to log into your ISP’s modem router and put it in bridge mode.

Okay. I’ll give it try. Thanks. Did you need to also enable UPnP on the Dream Machine Pro?

Check out this thread

I’m already in Bridge Mode. Any other suggestions?

I have the non-pro Dream Machine.

So I had spent quite a lot of time to understand why port forwarding wasn’t working on my UDM Pro, even contacted Ubiquiti support but they said that everything looks ok settings wise.
Just now I’ve disable the VPN setting and Port Forwarding works. Tested both Plex and Roon ARC and both work flawlessly.

1 Like

What country and ISP ?

There’s a chance your carrier is using Carrier Grade NAT or CGNAT. It’s quite common now. The result is Roon can’t forward the port. There are lots of ways it can be done but Roon has chosen not to.

You may be able to call your provider and have them issue you a static ip. In my case they want more money for that option.

I have the UDM Pro SE.

UPnP is disabled, onlusten forwarded the port.