Unable to access web UI

I have a NUC7PJIH with dietpi / Roon Server which works fine (playing music, setting audio, everything works).

  • I am unable to access the web UI from my Windows PC
  • When I enter the IP in a browser (Edge, Chrome, Firefox), I get a ERR_CONNECTION_REFUSED message back
  • Same result from a Samsung tablet’s browser
  • The Roon Remote on both the windows PC and the Samsung tablet connect to Roon Server just fine.
  • I also tried to get access to the UI by going through settings / setup / configure Roon OS devices, but I don’t get any connection that way either.

I have done a clean reinstall of dietpi / Roon Server - no change
I have done a clean install of Windows 10 / Roon Server - same behavior.
This issue was not present a month ago with dietpi / Roon Server. Could the latest Roon Server Update have something to do with the issue?

As a final resort I have installed Roon Server on a physically different Windows Machine. Same behavior.
So it doesn’t seem to be

  • the hardware
  • ditepi
  • Windows

Little left besides the new Roon Server Update. Guys, please fix this!

I’m unclear what you are trying to do or achieve. Roon Server doesn’t have a web interface and I’d expect DietPI to run on an RPi not a NUC.

Perhaps you could explain exactly what setup you have, i.e. Roon server, music store, network, bridge, DAC etc? Thanks.

you possibly just pointed me in the direction, where the confusion might be buried. I have installed ROCK on a NUC before and I had to add missing codecs through ROCK’s web UI.
The UI looks like this (not my screenshot, just one off the web from a Nucleus):

I was looking for this UI, because it also allows to shut down or restart a headless Roon Server. The restart functionality is missing from Roon Remote. After your puzzled answer I think the UI might only be present in ROCK, but not in Roon Server as installed on top of another OS.
As for my setup, it is fairly standard. NAS, Roon Server on a separate NUC7PJYH. The NUC runs dietpi (currently Windows after my efforts to find the cause of the missing web UI). dietpi exists in a UEFI / x64 flavor, which is handy if you want to run Roon Server on a non ROCK capable machine, like my NUC7PJYH (which only supports UEFI boot).

I believe that is correct. Roon Server installed on, for example, Ubuntu does not have a Web-Gui. If you need to start or stop Roon Server manually you’ll need to do this from the command line, i.e. ssh. On Ubuntu it would be:

sudo systemctl status roonserver.service – Check current status of the service
sudo systemctl stop | start | restart roonserver.service – Use either stop, start or restart to manually control the service

Ubuntu will install on the NUC (UEFI) and I’m sure will most flavours of Linux.

Thanks, Martin
Do you think ubuntu server would be a better choice than dietpi?
I gave ubuntu server a try this afternoon during my troubleshooting, but got lost trying to install ffmpeg and alsa before installing Roon Server. The more I looked to more complicated it seemed to become.
The beauty of dietpi for a noob like me is that the ffmpeg stuff is all taken care of by the Roon Server installation script.

Dietpi in my opinion would be better as it is stripped down to the essentials, you don’t need a full OS for roon.

I use Ubuntu Server, which is headless, and I only install software that is absolutely needed. I only run the LTS versions which means it is supported for 5 years and is pretty robust and reliable. But my server also provides my network storage, folder synchronisation, backup, CCTV and Plex.

Both are built on the Debian architecture, so the commands I shared earlier should work for DietPi too. So, stick with what you’re comfortable. :slight_smile:

Thanks @Martin_Webster
these commands worked on dietpi

1 Like